summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 452b7fdbf..772d08f84 100755
--- a/debian/rules
+++ b/debian/rules
@@ -57,6 +57,11 @@ ifeq ($(DEB_HOST_ARCH_OS),hurd)
57FORCE_LIBS := LIBS=-lcrypt 57FORCE_LIBS := LIBS=-lcrypt
58endif 58endif
59 59
60# SELinux support?
61ifeq ($(DEB_HOST_ARCH_OS),linux)
62SELINUX := --with-selinux
63endif
64
60# Change the version string to include the Debian version 65# Change the version string to include the Debian version
61SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') 66SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//')
62 67
@@ -66,7 +71,7 @@ build-deb: build-deb-stamp
66build-deb-stamp: 71build-deb-stamp:
67 dh_testdir 72 dh_testdir
68 mkdir -p build-deb 73 mkdir -p build-deb
69 cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit 74 cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit $(SELINUX)
70 75
71ifeq ($(DEB_HOST_ARCH_OS),linux) 76ifeq ($(DEB_HOST_ARCH_OS),linux)
72 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). 77 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999).