summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 6 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 4707023bf..55de7927b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,8 +15,6 @@ else
15OPTFLAGS := -O0 15OPTFLAGS := -O0
16endif 16endif
17 17
18VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2 | sed 's/.*://')
19DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
20DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) 18DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
21 19
22# Take account of old dpkg-architecture output. 20# Take account of old dpkg-architecture output.
@@ -27,9 +25,6 @@ ifeq ($(DEB_HOST_ARCH_OS),)
27 endif 25 endif
28endif 26endif
29 27
30CLIENT_UDEB := openssh-client-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
31SERVER_UDEB := openssh-server-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
32
33ifeq (,$(wildcard /usr/bin/po2debconf)) 28ifeq (,$(wildcard /usr/bin/po2debconf))
34PO2DEBCONF := no 29PO2DEBCONF := no
35MINDEBCONFVER := 0.5 30MINDEBCONFVER := 0.5
@@ -278,9 +273,9 @@ binary-openssh-client-udeb: build install
278 dh_installdeb 273 dh_installdeb
279 install -p -o root -g root -m 755 debian/openssh-client-udeb.isinstallable debian/openssh-client-udeb/DEBIAN/isinstallable 274 install -p -o root -g root -m 755 debian/openssh-client-udeb.isinstallable debian/openssh-client-udeb/DEBIAN/isinstallable
280 dh_shlibdeps 275 dh_shlibdeps
281 dh_gencontrol -- -fdebian/files~ 276 dh_gencontrol
282 dpkg-distaddfile $(CLIENT_UDEB) debian-installer optional 277 dh_md5sums
283 dh_builddeb --filename=$(CLIENT_UDEB) 278 dh_builddeb
284 279
285binary-openssh-server-udeb: DH_OPTIONS=-popenssh-server-udeb 280binary-openssh-server-udeb: DH_OPTIONS=-popenssh-server-udeb
286binary-openssh-server-udeb: build install 281binary-openssh-server-udeb: build install
@@ -291,9 +286,9 @@ binary-openssh-server-udeb: build install
291 dh_fixperms 286 dh_fixperms
292 dh_installdeb 287 dh_installdeb
293 dh_shlibdeps 288 dh_shlibdeps
294 dh_gencontrol -- -fdebian/files~ 289 dh_gencontrol
295 dpkg-distaddfile $(SERVER_UDEB) debian-installer optional 290 dh_md5sums
296 dh_builddeb --filename=$(SERVER_UDEB) 291 dh_builddeb
297 292
298binary: binary-indep binary-arch 293binary: binary-indep binary-arch
299 294