diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/.gitignore | 1 | ||||
-rwxr-xr-x | debian/adjust-openssl-dependencies | 2 | ||||
-rw-r--r-- | debian/changelog | 6 | ||||
-rw-r--r-- | debian/control | 31 | ||||
-rwxr-xr-x | debian/openssh-client-ssh1.install | 5 | ||||
-rwxr-xr-x | debian/rules | 10 |
6 files changed, 9 insertions, 46 deletions
diff --git a/debian/.gitignore b/debian/.gitignore index 3c767d5e5..988323b00 100644 --- a/debian/.gitignore +++ b/debian/.gitignore | |||
@@ -1,7 +1,6 @@ | |||
1 | /*.debhelper* | 1 | /*.debhelper* |
2 | /*substvars | 2 | /*substvars |
3 | /build-deb | 3 | /build-deb |
4 | /build-deb-ssh1 | ||
5 | /build-udeb | 4 | /build-udeb |
6 | /files | 5 | /files |
7 | /keygen-test/key1 | 6 | /keygen-test/key1 |
diff --git a/debian/adjust-openssl-dependencies b/debian/adjust-openssl-dependencies index b9799c410..5113ac164 100755 --- a/debian/adjust-openssl-dependencies +++ b/debian/adjust-openssl-dependencies | |||
@@ -3,7 +3,6 @@ | |||
3 | # Must be run after dpkg-shlibdeps. | 3 | # Must be run after dpkg-shlibdeps. |
4 | 4 | ||
5 | client=debian/openssh-client.substvars | 5 | client=debian/openssh-client.substvars |
6 | client_ssh1=debian/openssh-client-ssh1.substvars | ||
7 | server=debian/openssh-server.substvars | 6 | server=debian/openssh-server.substvars |
8 | 7 | ||
9 | libssl_version="$(dpkg-query -W libssl1.0-dev 2>/dev/null | cut -f2)" | 8 | libssl_version="$(dpkg-query -W libssl1.0-dev 2>/dev/null | cut -f2)" |
@@ -20,7 +19,6 @@ libssl_package="$(sed -n 's/.*[= ]\(libssl[0-9][a-z0-9+.-]*\).*/\1/p' "$client") | |||
20 | if [ "$libssl_package" ]; then | 19 | if [ "$libssl_package" ]; then |
21 | new_dep="$libssl_package (>= $libssl_version)" | 20 | new_dep="$libssl_package (>= $libssl_version)" |
22 | sed -i "/^shlibs:Depends=/s/\$/, $new_dep/" "$client" | 21 | sed -i "/^shlibs:Depends=/s/\$/, $new_dep/" "$client" |
23 | sed -i "/^shlibs:Depends=/s/\$/, $new_dep/" "$client_ssh1" | ||
24 | sed -i "/^shlibs:Depends=/s/\$/, $new_dep/" "$server" | 22 | sed -i "/^shlibs:Depends=/s/\$/, $new_dep/" "$server" |
25 | fi | 23 | fi |
26 | 24 | ||
diff --git a/debian/changelog b/debian/changelog index 447d5fc58..8d01ac39d 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,3 +1,9 @@ | |||
1 | openssh (1:7.5p1-8) UNRELEASED; urgency=medium | ||
2 | |||
3 | * Drop openssh-client-ssh1, now built by a separate source package. | ||
4 | |||
5 | -- Colin Watson <cjwatson@debian.org> Sun, 27 Aug 2017 23:24:58 +0100 | ||
6 | |||
1 | openssh (1:7.5p1-7) unstable; urgency=medium | 7 | openssh (1:7.5p1-7) unstable; urgency=medium |
2 | 8 | ||
3 | * Fix spelling of RuntimeDirectoryMode (closes: #872976). | 9 | * Fix spelling of RuntimeDirectoryMode (closes: #872976). |
diff --git a/debian/control b/debian/control index 411731a4a..838ec154f 100644 --- a/debian/control +++ b/debian/control | |||
@@ -66,37 +66,6 @@ Description: secure shell (SSH) client, for secure access to remote machines | |||
66 | ssh replaces the insecure rsh, rcp and rlogin programs, which are | 66 | ssh replaces the insecure rsh, rcp and rlogin programs, which are |
67 | obsolete for most purposes. | 67 | obsolete for most purposes. |
68 | 68 | ||
69 | Package: openssh-client-ssh1 | ||
70 | Priority: extra | ||
71 | Architecture: any | ||
72 | Depends: openssh-client (= ${binary:Version}), | ||
73 | ${misc:Depends}, | ||
74 | ${shlibs:Depends}, | ||
75 | Multi-Arch: foreign | ||
76 | Description: secure shell (SSH) client for legacy SSH1 protocol | ||
77 | This is the portable version of OpenSSH, a free implementation of | ||
78 | the Secure Shell protocol as specified by the IETF secsh working | ||
79 | group. | ||
80 | . | ||
81 | Ssh (Secure Shell) is a program for logging into a remote machine | ||
82 | and for executing commands on a remote machine. | ||
83 | It provides secure encrypted communications between two untrusted | ||
84 | hosts over an insecure network. X11 connections and arbitrary TCP/IP | ||
85 | ports can also be forwarded over the secure channel. | ||
86 | It can be used to provide applications with a secure communication | ||
87 | channel. | ||
88 | . | ||
89 | This package provides the ssh1 and scp1 clients and the ssh-keygen1 | ||
90 | utility, all built with support for the legacy SSH1 protocol. This | ||
91 | protocol is obsolete and should not normally be used, but in some cases | ||
92 | there may be no alternative way to connect to outdated servers. | ||
93 | . | ||
94 | In some countries it may be illegal to use any encryption at all | ||
95 | without a special permit. | ||
96 | . | ||
97 | ssh replaces the insecure rsh, rcp and rlogin programs, which are | ||
98 | obsolete for most purposes. | ||
99 | |||
100 | Package: openssh-server | 69 | Package: openssh-server |
101 | Priority: optional | 70 | Priority: optional |
102 | Architecture: any | 71 | Architecture: any |
diff --git a/debian/openssh-client-ssh1.install b/debian/openssh-client-ssh1.install deleted file mode 100755 index 60a8bc58a..000000000 --- a/debian/openssh-client-ssh1.install +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | #! /usr/bin/dh-exec | ||
2 | |||
3 | debian/build-deb-ssh1/scp => usr/bin/scp1 | ||
4 | debian/build-deb-ssh1/ssh => usr/bin/ssh1 | ||
5 | debian/build-deb-ssh1/ssh-keygen => usr/bin/ssh-keygen1 | ||
diff --git a/debian/rules b/debian/rules index c1aa9785c..9201dbd5a 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -132,7 +132,6 @@ override_dh_autoreconf-indep: | |||
132 | 132 | ||
133 | override_dh_auto_configure-arch: | 133 | override_dh_auto_configure-arch: |
134 | dh_auto_configure -Bdebian/build-deb -- $(confflags) | 134 | dh_auto_configure -Bdebian/build-deb -- $(confflags) |
135 | dh_auto_configure -Bdebian/build-deb-ssh1 -- $(confflags) --with-ssh1 | ||
136 | dh_auto_configure -Bdebian/build-udeb -- $(confflags_udeb) | 135 | dh_auto_configure -Bdebian/build-udeb -- $(confflags_udeb) |
137 | 136 | ||
138 | override_dh_auto_configure-indep: | 137 | override_dh_auto_configure-indep: |
@@ -143,7 +142,6 @@ override_dh_auto_build-arch: | |||
143 | cd debian/build-udeb && ./config.status | 142 | cd debian/build-udeb && ./config.status |
144 | 143 | ||
145 | $(MAKE) -C debian/build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' | 144 | $(MAKE) -C debian/build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' |
146 | $(MAKE) -C debian/build-deb-ssh1 $(PARALLEL) SSH_PROGRAM='/usr/bin/ssh1' ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp ssh-keygen | ||
147 | $(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen | 145 | $(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen |
148 | 146 | ||
149 | $(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG) | 147 | $(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG) |
@@ -165,7 +163,7 @@ endif | |||
165 | override_dh_auto_test-indep: | 163 | override_dh_auto_test-indep: |
166 | 164 | ||
167 | override_dh_auto_clean: | 165 | override_dh_auto_clean: |
168 | rm -rf debian/build-deb debian/build-deb-ssh1 debian/build-udeb | 166 | rm -rf debian/build-deb debian/build-udeb |
169 | ifeq ($(RUN_TESTS),yes) | 167 | ifeq ($(RUN_TESTS),yes) |
170 | $(MAKE) -C debian/keygen-test clean | 168 | $(MAKE) -C debian/keygen-test clean |
171 | endif | 169 | endif |
@@ -197,10 +195,8 @@ override_dh_install-indep: | |||
197 | dh_install | 195 | dh_install |
198 | 196 | ||
199 | override_dh_installdocs: | 197 | override_dh_installdocs: |
200 | dh_installdocs \ | 198 | dh_installdocs -Nopenssh-server -Nopenssh-sftp-server |
201 | -Nopenssh-client-ssh1 -Nopenssh-server -Nopenssh-sftp-server | 199 | dh_installdocs -popenssh-server -popenssh-sftp-server \ |
202 | dh_installdocs \ | ||
203 | -popenssh-client-ssh1 -popenssh-server -popenssh-sftp-server \ | ||
204 | --link-doc=openssh-client | 200 | --link-doc=openssh-client |
205 | # Avoid breaking dh_installexamples later. | 201 | # Avoid breaking dh_installexamples later. |
206 | mkdir -p debian/openssh-server/usr/share/doc/openssh-client | 202 | mkdir -p debian/openssh-server/usr/share/doc/openssh-client |