diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 2 | ||||
-rw-r--r-- | debian/config | 4 | ||||
-rw-r--r-- | debian/postinst | 4 | ||||
-rw-r--r-- | debian/preinst | 6 |
4 files changed, 9 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog index d11a8a472..2c6564368 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -5,6 +5,8 @@ openssh (1:3.8.1p1-5) UNRELEASED; urgency=low | |||
5 | * Remove Suggests: dnsutils, as it was only needed for | 5 | * Remove Suggests: dnsutils, as it was only needed for |
6 | make-ssh-known-hosts (#93265), which has been replaced by ssh-keyscan. | 6 | make-ssh-known-hosts (#93265), which has been replaced by ssh-keyscan. |
7 | * Disable shadow password support in openssh-server-udeb. | 7 | * Disable shadow password support in openssh-server-udeb. |
8 | * Fix bashisms in maintainer scripts (thanks, David Weinehall; partial fix | ||
9 | for #258517). | ||
8 | 10 | ||
9 | -- Colin Watson <cjwatson@debian.org> Wed, 2 Jun 2004 14:26:18 -0300 | 11 | -- Colin Watson <cjwatson@debian.org> Wed, 2 Jun 2004 14:26:18 -0300 |
10 | 12 | ||
diff --git a/debian/config b/debian/config index ea737a081..b5cff528c 100644 --- a/debian/config +++ b/debian/config | |||
@@ -3,7 +3,7 @@ | |||
3 | action=$1 | 3 | action=$1 |
4 | version=$2 | 4 | version=$2 |
5 | 5 | ||
6 | if [ -d /etc/ssh-nonfree -a ! -d /etc/ssh ]; then | 6 | if [ -d /etc/ssh-nonfree ] && [ ! -d /etc/ssh ]; then |
7 | version=1.2.27 | 7 | version=1.2.27 |
8 | cp -a /etc/ssh-nonfree /etc/ssh | 8 | cp -a /etc/ssh-nonfree /etc/ssh |
9 | fi | 9 | fi |
@@ -30,7 +30,7 @@ else | |||
30 | db_fset ssh/use_old_init_script seen true | 30 | db_fset ssh/use_old_init_script seen true |
31 | fi | 31 | fi |
32 | 32 | ||
33 | if [ -z "$version" -a ! -e /etc/ssh/sshd_config ] | 33 | if [ -z "$version" ] && [ ! -e /etc/ssh/sshd_config ] |
34 | then | 34 | then |
35 | db_input medium ssh/protocol2_only || true | 35 | db_input medium ssh/protocol2_only || true |
36 | fi | 36 | fi |
diff --git a/debian/postinst b/debian/postinst index b641769ba..ac5e1c555 100644 --- a/debian/postinst +++ b/debian/postinst | |||
@@ -28,9 +28,9 @@ check_idea_key() { | |||
28 | 28 | ||
29 | 29 | ||
30 | create_key() { | 30 | create_key() { |
31 | local msg="$1" | 31 | msg="$1" |
32 | shift | 32 | shift |
33 | local file="$1" | 33 | file="$1" |
34 | shift | 34 | shift |
35 | 35 | ||
36 | if [ ! -f "$file" ] ; then | 36 | if [ ! -f "$file" ] ; then |
diff --git a/debian/preinst b/debian/preinst index 320d4df2a..e22d0aa5d 100644 --- a/debian/preinst +++ b/debian/preinst | |||
@@ -3,11 +3,11 @@ | |||
3 | action=$1 | 3 | action=$1 |
4 | version=$2 | 4 | version=$2 |
5 | 5 | ||
6 | if [ -d /etc/ssh-nonfree -a ! -d /etc/ssh ]; then | 6 | if [ -d /etc/ssh-nonfree ] && [ ! -d /etc/ssh ]; then |
7 | version=1.2.27 | 7 | version=1.2.27 |
8 | fi | 8 | fi |
9 | 9 | ||
10 | if [ "$action" = upgrade -o "$action" = install ] | 10 | if [ "$action" = upgrade ] || [ "$action" = install ] |
11 | then | 11 | then |
12 | # check if debconf is missing | 12 | # check if debconf is missing |
13 | if ! test -f /usr/share/debconf/confmodule | 13 | if ! test -f /usr/share/debconf/confmodule |
@@ -39,7 +39,7 @@ EOF | |||
39 | # work around for missing debconf | 39 | # work around for missing debconf |
40 | db_get() { : ; } | 40 | db_get() { : ; } |
41 | RET=true | 41 | RET=true |
42 | if [ -d /etc/ssh-nonfree -a ! -d /etc/ssh ]; then | 42 | if [ -d /etc/ssh-nonfree ] && [ ! -d /etc/ssh ]; then |
43 | cp -a /etc/ssh-nonfree /etc/ssh | 43 | cp -a /etc/ssh-nonfree /etc/ssh |
44 | fi | 44 | fi |
45 | else | 45 | else |