diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 2 | ||||
-rwxr-xr-x | debian/rules | 8 |
2 files changed, 6 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog index 1b0e27201..42f4e0ccc 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -20,6 +20,8 @@ openssh (1:6.5p1-1) UNRELEASED; urgency=medium | |||
20 | Daniel Kahn Gillmor; closes: #732441). | 20 | Daniel Kahn Gillmor; closes: #732441). |
21 | * Add the pam_keyinit session module, to create a new session keyring on | 21 | * Add the pam_keyinit session module, to create a new session keyring on |
22 | login (closes: #734816). | 22 | login (closes: #734816). |
23 | * Incorporate default path changes from shadow 1:4.0.18.1-8, removing | ||
24 | /usr/bin/X11 (closes: #644521). | ||
23 | 25 | ||
24 | -- Colin Watson <cjwatson@debian.org> Sun, 09 Feb 2014 15:52:14 +0000 | 26 | -- Colin Watson <cjwatson@debian.org> Sun, 09 Feb 2014 15:52:14 +0000 |
25 | 27 | ||
diff --git a/debian/rules b/debian/rules index 1b1e2d456..5b0d8f9d6 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -47,11 +47,11 @@ SSH_EXTRAVERSION := $(DISTRIBUTION)-$(shell dpkg-parsechangelog | sed -n -e '/^V | |||
47 | 47 | ||
48 | DISTRIBUTOR := $(shell if dpkg-vendor --derives-from Ubuntu 2>/dev/null; then echo Ubuntu; else echo Debian; fi) | 48 | DISTRIBUTOR := $(shell if dpkg-vendor --derives-from Ubuntu 2>/dev/null; then echo Ubuntu; else echo Debian; fi) |
49 | ifeq ($(DISTRIBUTOR),Ubuntu) | 49 | ifeq ($(DISTRIBUTOR),Ubuntu) |
50 | DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games | 50 | DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games |
51 | else | 51 | else |
52 | DEFAULT_PATH := /usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games | 52 | DEFAULT_PATH := /usr/local/bin:/usr/bin:/bin:/usr/games |
53 | endif | 53 | endif |
54 | SUPERUSER_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11 | 54 | SUPERUSER_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin |
55 | 55 | ||
56 | ifeq ($(DISTRIBUTOR),Ubuntu) | 56 | ifeq ($(DISTRIBUTOR),Ubuntu) |
57 | server_recommends := ssh-import-id | 57 | server_recommends := ssh-import-id |
@@ -93,7 +93,7 @@ endif | |||
93 | confflags += --with-xauth=/usr/bin/xauth | 93 | confflags += --with-xauth=/usr/bin/xauth |
94 | confflags_udeb += --without-xauth | 94 | confflags_udeb += --without-xauth |
95 | 95 | ||
96 | # Default paths. The udeb build has /usr/bin/X11 and /usr/games removed. | 96 | # Default paths. The udeb build has /usr/games removed. |
97 | confflags += --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH) | 97 | confflags += --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH) |
98 | confflags_udeb += --with-default-path=/usr/local/bin:/usr/bin:/bin --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin | 98 | confflags_udeb += --with-default-path=/usr/local/bin:/usr/bin:/bin --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin |
99 | 99 | ||