diff options
Diffstat (limited to 'debian')
-rwxr-xr-x | debian/agent-launch | 4 | ||||
-rw-r--r-- | debian/changelog | 2 |
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/agent-launch b/debian/agent-launch index 40479b868..79c75a50b 100755 --- a/debian/agent-launch +++ b/debian/agent-launch | |||
@@ -11,7 +11,7 @@ if [ "$1" = start ]; then | |||
11 | if [ -z "$SSH_AUTH_SOCK" ] && grep -s -q '^use-ssh-agent$' /etc/X11/Xsession.options; then | 11 | if [ -z "$SSH_AUTH_SOCK" ] && grep -s -q '^use-ssh-agent$' /etc/X11/Xsession.options; then |
12 | S="$XDG_RUNTIME_DIR/openssh_agent" | 12 | S="$XDG_RUNTIME_DIR/openssh_agent" |
13 | dbus-update-activation-environment --verbose --systemd SSH_AUTH_SOCK=$S SSH_AGENT_LAUNCHER=openssh | 13 | dbus-update-activation-environment --verbose --systemd SSH_AUTH_SOCK=$S SSH_AGENT_LAUNCHER=openssh |
14 | if type initctl >/dev/null 2>&1; then | 14 | if [ "$UPSTART_SESSION" ] && type initctl >/dev/null 2>&1; then |
15 | initctl set-env --global SSH_AUTH_SOCK=$S | 15 | initctl set-env --global SSH_AUTH_SOCK=$S |
16 | fi | 16 | fi |
17 | exec ssh-agent -D -a $S | 17 | exec ssh-agent -D -a $S |
@@ -19,7 +19,7 @@ if [ "$1" = start ]; then | |||
19 | elif [ "$1" = stop ]; then | 19 | elif [ "$1" = stop ]; then |
20 | if [ "$SSH_AGENT_LAUNCHER" = openssh ]; then | 20 | if [ "$SSH_AGENT_LAUNCHER" = openssh ]; then |
21 | dbus-update-activation-environment --systemd SSH_AUTH_SOCK= | 21 | dbus-update-activation-environment --systemd SSH_AUTH_SOCK= |
22 | if type initctl >/dev/null 2>&1; then | 22 | if [ "$UPSTART_SESSION" ] && type initctl >/dev/null 2>&1; then |
23 | initctl unset-env --global SSH_AUTH_SOCK | 23 | initctl unset-env --global SSH_AUTH_SOCK |
24 | fi | 24 | fi |
25 | fi | 25 | fi |
diff --git a/debian/changelog b/debian/changelog index ae5b84e09..5dcf4438e 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -2,6 +2,8 @@ openssh (1:7.5p1-4) UNRELEASED; urgency=medium | |||
2 | 2 | ||
3 | * Drop README.Debian section on privilege separation, as it's no longer | 3 | * Drop README.Debian section on privilege separation, as it's no longer |
4 | optional. | 4 | optional. |
5 | * Only call "initctl set-env" from agent-launch if $UPSTART_SESSION is set | ||
6 | (LP: #1689299). | ||
5 | 7 | ||
6 | -- Colin Watson <cjwatson@debian.org> Wed, 03 May 2017 12:23:16 +0100 | 8 | -- Colin Watson <cjwatson@debian.org> Wed, 03 May 2017 12:23:16 +0100 |
7 | 9 | ||