diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 2 | ||||
-rw-r--r-- | debian/openssh-client.postinst | 21 | ||||
-rw-r--r-- | debian/openssh-client.templates.master | 2 | ||||
-rw-r--r-- | debian/openssh-server.dirs | 2 | ||||
-rw-r--r-- | debian/openssh-server.postinst | 26 | ||||
-rw-r--r-- | debian/po/ca.po | 4 | ||||
-rw-r--r-- | debian/po/cs.po | 4 | ||||
-rw-r--r-- | debian/po/da.po | 4 | ||||
-rw-r--r-- | debian/po/de.po | 4 | ||||
-rw-r--r-- | debian/po/el.po | 4 | ||||
-rw-r--r-- | debian/po/es.po | 4 | ||||
-rw-r--r-- | debian/po/fi.po | 4 | ||||
-rw-r--r-- | debian/po/fr.po | 4 | ||||
-rw-r--r-- | debian/po/it.po | 4 | ||||
-rw-r--r-- | debian/po/ja.po | 4 | ||||
-rw-r--r-- | debian/po/nl.po | 4 | ||||
-rw-r--r-- | debian/po/pl.po | 4 | ||||
-rw-r--r-- | debian/po/pt_BR.po | 4 | ||||
-rw-r--r-- | debian/po/ru.po | 4 | ||||
-rw-r--r-- | debian/po/templates.pot | 2 | ||||
-rw-r--r-- | debian/po/tr.po | 6 | ||||
-rw-r--r-- | debian/po/uk.po | 4 | ||||
-rw-r--r-- | debian/po/zh_CN.po | 4 | ||||
-rwxr-xr-x | debian/rules | 14 | ||||
-rw-r--r-- | debian/ssh-askpass-gnome.dirs | 2 | ||||
-rw-r--r-- | debian/ssh-askpass-gnome.postinst | 7 | ||||
-rw-r--r-- | debian/ssh-askpass-gnome.prerm | 2 |
27 files changed, 93 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog index df48a4003..aafb4e26f 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -12,6 +12,8 @@ openssh (1:4.1p1-1) UNRELEASED; urgency=low | |||
12 | to PasswordAuthentication by default, since it now supports PAM and | 12 | to PasswordAuthentication by default, since it now supports PAM and |
13 | apparently works better with a non-threaded sshd (closes: #247521). | 13 | apparently works better with a non-threaded sshd (closes: #247521). |
14 | * openssh-server Suggests: rssh (closes: #233012). | 14 | * openssh-server Suggests: rssh (closes: #233012). |
15 | * Change libexecdir to /usr/lib/openssh, and fix up various alternatives | ||
16 | and configuration files to match (closes: #87900, #151321). | ||
15 | 17 | ||
16 | -- Colin Watson <cjwatson@debian.org> Thu, 26 May 2005 13:51:50 +0100 | 18 | -- Colin Watson <cjwatson@debian.org> Thu, 26 May 2005 13:51:50 +0100 |
17 | 19 | ||
diff --git a/debian/openssh-client.postinst b/debian/openssh-client.postinst index 2168dc1f1..4744a34a1 100644 --- a/debian/openssh-client.postinst +++ b/debian/openssh-client.postinst | |||
@@ -59,13 +59,28 @@ set_ssh_permissions() { | |||
59 | fi | 59 | fi |
60 | fi | 60 | fi |
61 | 61 | ||
62 | # libexecdir changed, so migrate old statoverrides. | ||
63 | if [ -x /usr/sbin/dpkg-statoverride ] && | ||
64 | override="$(dpkg-statoverride --list /usr/lib/ssh-keysign)"; then | ||
65 | override_user="${override%% *}" | ||
66 | override="${override#* }" | ||
67 | override_group="${override%% *}" | ||
68 | override="${override#* }" | ||
69 | override_mode="${override%% *}" | ||
70 | if dpkg-statoverride --update --add \ | ||
71 | "$override_user" "$override_group" "$override_mode" \ | ||
72 | /usr/lib/openssh/ssh-keysign; then | ||
73 | dpkg-statoverride --remove /usr/lib/ssh-keysign || true | ||
74 | fi | ||
75 | fi | ||
76 | |||
62 | if [ ! -x /usr/sbin/dpkg-statoverride ] || \ | 77 | if [ ! -x /usr/sbin/dpkg-statoverride ] || \ |
63 | ! dpkg-statoverride --list /usr/lib/ssh-keysign >/dev/null ; then | 78 | ! dpkg-statoverride --list /usr/lib/openssh/ssh-keysign >/dev/null; then |
64 | db_get ssh/SUID_client | 79 | db_get ssh/SUID_client |
65 | if [ "$RET" = "false" ] ; then | 80 | if [ "$RET" = "false" ] ; then |
66 | chmod 0755 /usr/lib/ssh-keysign | 81 | chmod 0755 /usr/lib/openssh/ssh-keysign |
67 | elif [ "$RET" = "true" ] ; then | 82 | elif [ "$RET" = "true" ] ; then |
68 | chmod 4755 /usr/lib/ssh-keysign | 83 | chmod 4755 /usr/lib/openssh/ssh-keysign |
69 | fi | 84 | fi |
70 | fi | 85 | fi |
71 | } | 86 | } |
diff --git a/debian/openssh-client.templates.master b/debian/openssh-client.templates.master index 2a9594c66..1cb84bf04 100644 --- a/debian/openssh-client.templates.master +++ b/debian/openssh-client.templates.master | |||
@@ -1,7 +1,7 @@ | |||
1 | Template: ssh/SUID_client | 1 | Template: ssh/SUID_client |
2 | Type: boolean | 2 | Type: boolean |
3 | Default: true | 3 | Default: true |
4 | _Description: Do you want /usr/lib/ssh-keysign to be installed SUID root? | 4 | _Description: Do you want ssh-keysign to be installed SUID root? |
5 | You have the option of installing the ssh-keysign helper with the SUID bit | 5 | You have the option of installing the ssh-keysign helper with the SUID bit |
6 | set. | 6 | set. |
7 | . | 7 | . |
diff --git a/debian/openssh-server.dirs b/debian/openssh-server.dirs index 85ee171be..b28faf929 100644 --- a/debian/openssh-server.dirs +++ b/debian/openssh-server.dirs | |||
@@ -1,6 +1,6 @@ | |||
1 | etc/init.d | 1 | etc/init.d |
2 | etc/default | 2 | etc/default |
3 | usr/lib | 3 | usr/lib/openssh |
4 | usr/sbin | 4 | usr/sbin |
5 | usr/share/man/man5 | 5 | usr/share/man/man5 |
6 | usr/share/man/man8 | 6 | usr/share/man/man8 |
diff --git a/debian/openssh-server.postinst b/debian/openssh-server.postinst index 46813605f..fe6f50775 100644 --- a/debian/openssh-server.postinst +++ b/debian/openssh-server.postinst | |||
@@ -32,7 +32,7 @@ get_config_option() { | |||
32 | [ -f /etc/ssh/sshd_config ] || return | 32 | [ -f /etc/ssh/sshd_config ] || return |
33 | 33 | ||
34 | # TODO: actually only one '=' allowed after option | 34 | # TODO: actually only one '=' allowed after option |
35 | perl -ne 'print if s/^[[:space:]]*'"$option"'[[:space:]=]+//i' \ | 35 | perl -lne 's/\s+/ /g; print if s/^\s*'"$option"'[[:space:]=]+//i' \ |
36 | /etc/ssh/sshd_config | 36 | /etc/ssh/sshd_config |
37 | } | 37 | } |
38 | 38 | ||
@@ -41,15 +41,18 @@ set_config_option() { | |||
41 | option="$1" | 41 | option="$1" |
42 | value="$2" | 42 | value="$2" |
43 | 43 | ||
44 | perl -e ' | 44 | perl -le ' |
45 | $option = $ARGV[0]; $value = $ARGV[1]; $done = 0; | 45 | $option = $ARGV[0]; $value = $ARGV[1]; $done = 0; |
46 | while (<STDIN>) { | 46 | while (<STDIN>) { |
47 | if (s/^\s*\Q$option\E\s+.*/$option $value/) { | 47 | chomp; |
48 | (my $match = $_) =~ s/\s+/ /g; | ||
49 | if ($match =~ s/^\s*\Q$option\E\s+.*/$option $value/) { | ||
50 | $_ = $match; | ||
48 | $done = 1; | 51 | $done = 1; |
49 | } | 52 | } |
50 | print; | 53 | print; |
51 | } | 54 | } |
52 | print "\n$option $value\n" unless $done;' \ | 55 | print "$option $value" unless $done;' \ |
53 | "$option" "$value" \ | 56 | "$option" "$value" \ |
54 | < /etc/ssh/sshd_config > /etc/ssh/sshd_config.dpkg-new | 57 | < /etc/ssh/sshd_config > /etc/ssh/sshd_config.dpkg-new |
55 | chown --reference /etc/ssh/sshd_config /etc/ssh/sshd_config.dpkg-new | 58 | chown --reference /etc/ssh/sshd_config /etc/ssh/sshd_config.dpkg-new |
@@ -121,6 +124,14 @@ check_password_auth() { | |||
121 | } | 124 | } |
122 | 125 | ||
123 | 126 | ||
127 | move_subsystem_sftp() { | ||
128 | subsystem_sftp="$(get_config_option 'Subsystem sftp')" | ||
129 | if [ "$subsystem_sftp" = /usr/lib/sftp-server ]; then | ||
130 | set_config_option 'Subsystem sftp' /usr/lib/openssh/sftp-server | ||
131 | fi | ||
132 | } | ||
133 | |||
134 | |||
124 | create_sshdconfig() { | 135 | create_sshdconfig() { |
125 | if [ -e /etc/ssh/sshd_config ] ; then | 136 | if [ -e /etc/ssh/sshd_config ] ; then |
126 | if dpkg --compare-versions "$oldversion" lt-nl 1:1.3 ; then | 137 | if dpkg --compare-versions "$oldversion" lt-nl 1:1.3 ; then |
@@ -159,6 +170,11 @@ create_sshdconfig() { | |||
159 | check_password_auth | 170 | check_password_auth |
160 | fi | 171 | fi |
161 | 172 | ||
173 | # libexecdir changed, so fix up 'Subsystem sftp'. | ||
174 | if dpkg --compare-versions "$oldversion" lt 1:4.1p1-1; then | ||
175 | move_subsystem_sftp | ||
176 | fi | ||
177 | |||
162 | return 0 | 178 | return 0 |
163 | fi | 179 | fi |
164 | fi | 180 | fi |
@@ -260,7 +276,7 @@ KeepAlive yes | |||
260 | # Allow client to pass locale environment variables | 276 | # Allow client to pass locale environment variables |
261 | AcceptEnv LANG LC_* | 277 | AcceptEnv LANG LC_* |
262 | 278 | ||
263 | Subsystem sftp /usr/lib/sftp-server | 279 | Subsystem sftp /usr/lib/openssh/sftp-server |
264 | 280 | ||
265 | UsePAM yes | 281 | UsePAM yes |
266 | EOF | 282 | EOF |
diff --git a/debian/po/ca.po b/debian/po/ca.po index 31b446645..04fd74b6e 100644 --- a/debian/po/ca.po +++ b/debian/po/ca.po | |||
@@ -17,8 +17,8 @@ msgstr "" | |||
17 | #. Type: boolean | 17 | #. Type: boolean |
18 | #. Description | 18 | #. Description |
19 | #: ../openssh-client.templates.master:4 | 19 | #: ../openssh-client.templates.master:4 |
20 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 20 | msgid "Do you want ssh-keysign to be installed SUID root?" |
21 | msgstr "Voleu que el fitxer /usr/lib/ssh-keysign s'instal揃li SUID root?" | 21 | msgstr "Voleu que el fitxer ssh-keysign s'instal揃li SUID root?" |
22 | 22 | ||
23 | #. Type: boolean | 23 | #. Type: boolean |
24 | #. Description | 24 | #. Description |
diff --git a/debian/po/cs.po b/debian/po/cs.po index 50280ae75..245fcb4ba 100644 --- a/debian/po/cs.po +++ b/debian/po/cs.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Chcete /usr/lib/ssh-keysign nainstalovat jako SUID root?" | 30 | msgstr "Chcete ssh-keysign nainstalovat jako SUID root?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/da.po b/debian/po/da.po index 88fba1944..d469d3cae 100644 --- a/debian/po/da.po +++ b/debian/po/da.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Vil du have, at /usr/bin/ssh-keysign bliver installeret 'SUID root'?" | 30 | msgstr "Vil du have, at ssh-keysign bliver installeret 'SUID root'?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/de.po b/debian/po/de.po index 394227e7e..f48b8587b 100644 --- a/debian/po/de.po +++ b/debian/po/de.po | |||
@@ -27,8 +27,8 @@ msgstr "" | |||
27 | #. Type: boolean | 27 | #. Type: boolean |
28 | #. Description | 28 | #. Description |
29 | #: ../openssh-client.templates.master:4 | 29 | #: ../openssh-client.templates.master:4 |
30 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 30 | msgid "Do you want ssh-keysign to be installed SUID root?" |
31 | msgstr "Mchten Sie /usr/lib/ssh-keysign SUID-Root installieren?" | 31 | msgstr "Mchten Sie ssh-keysign SUID-Root installieren?" |
32 | 32 | ||
33 | #. Type: boolean | 33 | #. Type: boolean |
34 | #. Description | 34 | #. Description |
diff --git a/debian/po/el.po b/debian/po/el.po index 23195f3e9..345f1e5db 100644 --- a/debian/po/el.po +++ b/debian/po/el.po | |||
@@ -28,8 +28,8 @@ msgstr "" | |||
28 | #. Type: boolean | 28 | #. Type: boolean |
29 | #. Description | 29 | #. Description |
30 | #: ../openssh-client.templates.master:4 | 30 | #: ../openssh-client.templates.master:4 |
31 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 31 | msgid "Do you want ssh-keysign to be installed SUID root?" |
32 | msgstr "劉了竜竜 僚留 竜粒虜留留流竜竜 凌 /usr/lib/ssh-keysign SUID;" | 32 | msgstr "劉了竜竜 僚留 竜粒虜留留流竜竜 凌 ssh-keysign SUID;" |
33 | 33 | ||
34 | #. Type: boolean | 34 | #. Type: boolean |
35 | #. Description | 35 | #. Description |
diff --git a/debian/po/es.po b/debian/po/es.po index 65d8fe4c3..11ae193bd 100644 --- a/debian/po/es.po +++ b/debian/po/es.po | |||
@@ -43,8 +43,8 @@ msgstr "" | |||
43 | #. Type: boolean | 43 | #. Type: boolean |
44 | #. Description | 44 | #. Description |
45 | #: ../openssh-client.templates.master:4 | 45 | #: ../openssh-client.templates.master:4 |
46 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 46 | msgid "Do you want ssh-keysign to be installed SUID root?" |
47 | msgstr "Quiere instalar /usr/lib/ssh-keysign SUID root?" | 47 | msgstr "Quiere instalar ssh-keysign SUID root?" |
48 | 48 | ||
49 | #. Type: boolean | 49 | #. Type: boolean |
50 | #. Description | 50 | #. Description |
diff --git a/debian/po/fi.po b/debian/po/fi.po index 8b187fabe..dbc7ef98c 100644 --- a/debian/po/fi.po +++ b/debian/po/fi.po | |||
@@ -29,8 +29,8 @@ msgstr "" | |||
29 | #. Type: boolean | 29 | #. Type: boolean |
30 | #. Description | 30 | #. Description |
31 | #: ../openssh-client.templates.master:4 | 31 | #: ../openssh-client.templates.master:4 |
32 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 32 | msgid "Do you want ssh-keysign to be installed SUID root?" |
33 | msgstr "Haluatko, ett辰 /usr/lib/ssh-keygen asennetaan SUID root -oikeuksin?" | 33 | msgstr "Haluatko, ett辰 ssh-keygen asennetaan SUID root -oikeuksin?" |
34 | 34 | ||
35 | #. Type: boolean | 35 | #. Type: boolean |
36 | #. Description | 36 | #. Description |
diff --git a/debian/po/fr.po b/debian/po/fr.po index db77e6c98..6b15f7d16 100644 --- a/debian/po/fr.po +++ b/debian/po/fr.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Faut-il installer /usr/lib/ssh-keysign avec le bit SETUID activ?" | 30 | msgstr "Faut-il installer ssh-keysign avec le bit SETUID activ?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/it.po b/debian/po/it.po index e064af9fe..257555427 100644 --- a/debian/po/it.po +++ b/debian/po/it.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Si desidera installare /usr/lib/ssh-keysign come SUID-root?" | 30 | msgstr "Si desidera installare ssh-keysign come SUID-root?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/ja.po b/debian/po/ja.po index 914ba4500..2422dc9f9 100644 --- a/debian/po/ja.po +++ b/debian/po/ja.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "/usr/bin/ssh-keysign を SUID root でインストールしますか?" | 30 | msgstr "ssh-keysign を SUID root でインストールしますか?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/nl.po b/debian/po/nl.po index 95a2698fa..7e6897d15 100644 --- a/debian/po/nl.po +++ b/debian/po/nl.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Wilt u /usr/lib/ssh-keysign met SUID root installeren?" | 30 | msgstr "Wilt u ssh-keysign met SUID root installeren?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/pl.po b/debian/po/pl.po index 3b422c92c..cb9a1df8c 100644 --- a/debian/po/pl.po +++ b/debian/po/pl.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Czy chcesz aby /usr/lib/ssh-keysign by zainstalowany jako SUID root?" | 30 | msgstr "Czy chcesz aby ssh-keysign by zainstalowany jako SUID root?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/pt_BR.po b/debian/po/pt_BR.po index 6c8071955..c5df9efd1 100644 --- a/debian/po/pt_BR.po +++ b/debian/po/pt_BR.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "Deseja que que /usr/lib/ssh-keysign seja instalado SUID root ?" | 30 | msgstr "Deseja que que ssh-keysign seja instalado SUID root ?" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/po/ru.po b/debian/po/ru.po index d2e4cde60..923067022 100644 --- a/debian/po/ru.po +++ b/debian/po/ru.po | |||
@@ -27,8 +27,8 @@ msgstr "" | |||
27 | #. Type: boolean | 27 | #. Type: boolean |
28 | #. Description | 28 | #. Description |
29 | #: ../openssh-client.templates.master:4 | 29 | #: ../openssh-client.templates.master:4 |
30 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 30 | msgid "Do you want ssh-keysign to be installed SUID root?" |
31 | msgstr "莽塢堙 孑堊力徂墮 /usr/lib/ssh-keysign 冒 SUID root?" | 31 | msgstr "莽塢堙 孑堊力徂墮 ssh-keysign 冒 SUID root?" |
32 | 32 | ||
33 | #. Type: boolean | 33 | #. Type: boolean |
34 | #. Description | 34 | #. Description |
diff --git a/debian/po/templates.pot b/debian/po/templates.pot index 458b36ad1..abcfb0e9a 100644 --- a/debian/po/templates.pot +++ b/debian/po/templates.pot | |||
@@ -27,7 +27,7 @@ msgstr "" | |||
27 | #. Type: boolean | 27 | #. Type: boolean |
28 | #. Description | 28 | #. Description |
29 | #: ../openssh-client.templates.master:4 | 29 | #: ../openssh-client.templates.master:4 |
30 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 30 | msgid "Do you want ssh-keysign to be installed SUID root?" |
31 | msgstr "" | 31 | msgstr "" |
32 | 32 | ||
33 | #. Type: boolean | 33 | #. Type: boolean |
diff --git a/debian/po/tr.po b/debian/po/tr.po index 4134b65be..9b60d9a3e 100644 --- a/debian/po/tr.po +++ b/debian/po/tr.po | |||
@@ -18,10 +18,8 @@ msgstr "" | |||
18 | #. Type: boolean | 18 | #. Type: boolean |
19 | #. Description | 19 | #. Description |
20 | #: ../openssh-client.templates.master:4 | 20 | #: ../openssh-client.templates.master:4 |
21 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 21 | msgid "Do you want ssh-keysign to be installed SUID root?" |
22 | msgstr "" | 22 | msgstr "ssh-keysign'脹n root haklar脹yla kurulmas脹n脹 (SUID root) ister misiniz?" |
23 | "/usr/lib/ssh-keysign'脹n root haklar脹yla kurulmas脹n脹 (SUID root) ister " | ||
24 | "misiniz?" | ||
25 | 23 | ||
26 | #. Type: boolean | 24 | #. Type: boolean |
27 | #. Description | 25 | #. Description |
diff --git a/debian/po/uk.po b/debian/po/uk.po index 4ee9de985..9a238e36e 100644 --- a/debian/po/uk.po +++ b/debian/po/uk.po | |||
@@ -29,8 +29,8 @@ msgstr "" | |||
29 | #. Type: boolean | 29 | #. Type: boolean |
30 | #. Description | 30 | #. Description |
31 | #: ../openssh-client.templates.master:4 | 31 | #: ../openssh-client.templates.master:4 |
32 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 32 | msgid "Do you want ssh-keysign to be installed SUID root?" |
33 | msgstr "丼亳 弍舒亢舒亠 于亳, 仂弍 /usr/lib/ssh-keysign 仄舒于 于舒仆仂于仍亠仆亳亶 弍 SUID?" | 33 | msgstr "丼亳 弍舒亢舒亠 于亳, 仂弍 ssh-keysign 仄舒于 于舒仆仂于仍亠仆亳亶 弍 SUID?" |
34 | 34 | ||
35 | #. Type: boolean | 35 | #. Type: boolean |
36 | #. Description | 36 | #. Description |
diff --git a/debian/po/zh_CN.po b/debian/po/zh_CN.po index f8673f647..afe415bb8 100644 --- a/debian/po/zh_CN.po +++ b/debian/po/zh_CN.po | |||
@@ -26,8 +26,8 @@ msgstr "" | |||
26 | #. Type: boolean | 26 | #. Type: boolean |
27 | #. Description | 27 | #. Description |
28 | #: ../openssh-client.templates.master:4 | 28 | #: ../openssh-client.templates.master:4 |
29 | msgid "Do you want /usr/lib/ssh-keysign to be installed SUID root?" | 29 | msgid "Do you want ssh-keysign to be installed SUID root?" |
30 | msgstr "荀絨 /usr/lib/ssh-keysign 絎茖筝 SUID root 腮綺鐚" | 30 | msgstr "荀絨 ssh-keysign 絎茖筝 SUID root 腮綺鐚" |
31 | 31 | ||
32 | #. Type: boolean | 32 | #. Type: boolean |
33 | #. Description | 33 | #. Description |
diff --git a/debian/rules b/debian/rules index cbad70815..90bd7ba9e 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -58,12 +58,12 @@ build-deb: build-deb-stamp | |||
58 | build-deb-stamp: | 58 | build-deb-stamp: |
59 | dh_testdir | 59 | dh_testdir |
60 | mkdir -p build-deb | 60 | mkdir -p build-deb |
61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit | 61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit |
62 | 62 | ||
63 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). | 63 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). |
64 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h | 64 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h |
65 | 65 | ||
66 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' | 66 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/openssh/ssh-keysign' |
67 | # Support building on Debian 3.0 (with GNOME 1.4) and later. | 67 | # Support building on Debian 3.0 (with GNOME 1.4) and later. |
68 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ | 68 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ |
69 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ | 69 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ |
@@ -77,11 +77,11 @@ build-udeb: build-udeb-stamp | |||
77 | build-udeb-stamp: | 77 | build-udeb-stamp: |
78 | dh_testdir | 78 | dh_testdir |
79 | mkdir -p build-udeb | 79 | mkdir -p build-udeb |
80 | cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper | 80 | cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper |
81 | # Avoid libnsl linkage. Ugh. | 81 | # Avoid libnsl linkage. Ugh. |
82 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status | 82 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status |
83 | cd build-udeb && ./config.status | 83 | cd build-udeb && ./config.status |
84 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh scp sftp sshd ssh-keygen | 84 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/openssh/ssh-keysign' ssh scp sftp sshd ssh-keygen |
85 | touch build-udeb-stamp | 85 | touch build-udeb-stamp |
86 | 86 | ||
87 | clean: | 87 | clean: |
@@ -125,7 +125,7 @@ install: build | |||
125 | 125 | ||
126 | # Split off the server. | 126 | # Split off the server. |
127 | mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/ | 127 | mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/ |
128 | mv debian/openssh-client/usr/lib/sftp-server debian/openssh-server/usr/lib/ | 128 | mv debian/openssh-client/usr/lib/openssh/sftp-server debian/openssh-server/usr/lib/openssh/ |
129 | mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/ | 129 | mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/ |
130 | mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/ | 130 | mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/ |
131 | mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/ | 131 | mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/ |
@@ -137,9 +137,9 @@ install: build | |||
137 | 137 | ||
138 | ifneq ($(DEB_HOST_ARCH_OS),gnu) | 138 | ifneq ($(DEB_HOST_ARCH_OS),gnu) |
139 | if [ -f contrib/gnome-ssh-askpass2 ]; then \ | 139 | if [ -f contrib/gnome-ssh-askpass2 ]; then \ |
140 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \ | 140 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ |
141 | elif [ -f contrib/gnome-ssh-askpass1 ]; then \ | 141 | elif [ -f contrib/gnome-ssh-askpass1 ]; then \ |
142 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \ | 142 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ |
143 | fi | 143 | fi |
144 | install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 | 144 | install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 |
145 | uudecode -o debian/ssh-askpass-gnome/usr/share/pixmaps/ssh-askpass-gnome.png debian/ssh-askpass-gnome.png.uue | 145 | uudecode -o debian/ssh-askpass-gnome/usr/share/pixmaps/ssh-askpass-gnome.png debian/ssh-askpass-gnome.png.uue |
diff --git a/debian/ssh-askpass-gnome.dirs b/debian/ssh-askpass-gnome.dirs index e5d8d3904..8fdeef7ea 100644 --- a/debian/ssh-askpass-gnome.dirs +++ b/debian/ssh-askpass-gnome.dirs | |||
@@ -1,4 +1,4 @@ | |||
1 | usr/lib/ssh | 1 | usr/lib/openssh |
2 | usr/share/man/man1 | 2 | usr/share/man/man1 |
3 | usr/share/applications | 3 | usr/share/applications |
4 | usr/share/pixmaps | 4 | usr/share/pixmaps |
diff --git a/debian/ssh-askpass-gnome.postinst b/debian/ssh-askpass-gnome.postinst index 7441cca29..15290b711 100644 --- a/debian/ssh-askpass-gnome.postinst +++ b/debian/ssh-askpass-gnome.postinst | |||
@@ -24,9 +24,14 @@ set -e | |||
24 | 24 | ||
25 | case "$1" in | 25 | case "$1" in |
26 | configure) | 26 | configure) |
27 | if dpkg --compare-versions "$2" lt-nl 1:4.1p1-1; then | ||
28 | # libexecdir changed, so remove the obsolete alternative. | ||
29 | update-alternatives --quiet --remove ssh-askpass \ | ||
30 | /usr/lib/ssh/gnome-ssh-askpass | ||
31 | fi | ||
27 | update-alternatives --quiet \ | 32 | update-alternatives --quiet \ |
28 | --install /usr/bin/ssh-askpass ssh-askpass \ | 33 | --install /usr/bin/ssh-askpass ssh-askpass \ |
29 | /usr/lib/ssh/gnome-ssh-askpass 30 \ | 34 | /usr/lib/openssh/gnome-ssh-askpass 30 \ |
30 | --slave /usr/share/man/man1/ssh-askpass.1.gz \ | 35 | --slave /usr/share/man/man1/ssh-askpass.1.gz \ |
31 | ssh-askpass.1.gz /usr/share/man/man1/gnome-ssh-askpass.1.gz | 36 | ssh-askpass.1.gz /usr/share/man/man1/gnome-ssh-askpass.1.gz |
32 | 37 | ||
diff --git a/debian/ssh-askpass-gnome.prerm b/debian/ssh-askpass-gnome.prerm index 6f3f5756d..e85f2d4a7 100644 --- a/debian/ssh-askpass-gnome.prerm +++ b/debian/ssh-askpass-gnome.prerm | |||
@@ -17,7 +17,7 @@ set -e | |||
17 | 17 | ||
18 | case "$1" in | 18 | case "$1" in |
19 | remove|deconfigure) | 19 | remove|deconfigure) |
20 | update-alternatives --quiet --remove ssh-askpass /usr/lib/ssh/gnome-ssh-askpass | 20 | update-alternatives --quiet --remove ssh-askpass /usr/lib/openssh/gnome-ssh-askpass |
21 | # install-info --quiet --remove /usr/info/ssh-askpass.info.gz | 21 | # install-info --quiet --remove /usr/info/ssh-askpass.info.gz |
22 | ;; | 22 | ;; |
23 | upgrade) | 23 | upgrade) |