diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 2 | ||||
-rwxr-xr-x | debian/rules | 11 |
2 files changed, 11 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog index 64d7df278..b3f7fc49a 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -8,6 +8,8 @@ openssh (1:6.1p1-2) UNRELEASED; urgency=low | |||
8 | been long enough since the relevant vulnerability that we shouldn't | 8 | been long enough since the relevant vulnerability that we shouldn't |
9 | need these installed by default nowadays. | 9 | need these installed by default nowadays. |
10 | - Add an Upstart job (not currently used by default in Debian). | 10 | - Add an Upstart job (not currently used by default in Debian). |
11 | * Only build with -j if DEB_BUILD_OPTIONS=parallel=* is used (closes: | ||
12 | #694282). | ||
11 | 13 | ||
12 | -- Colin Watson <cjwatson@debian.org> Fri, 28 Sep 2012 17:54:42 +0100 | 14 | -- Colin Watson <cjwatson@debian.org> Fri, 28 Sep 2012 17:54:42 +0100 |
13 | 15 | ||
diff --git a/debian/rules b/debian/rules index 3dfbe6a66..a2efd3a0b 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -12,6 +12,13 @@ else | |||
12 | RUN_TESTS := | 12 | RUN_TESTS := |
13 | endif | 13 | endif |
14 | 14 | ||
15 | ifeq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) | ||
16 | PARALLEL := | ||
17 | else | ||
18 | PARALLEL := \ | ||
19 | -j$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) | ||
20 | endif | ||
21 | |||
15 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) | 22 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
16 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | 23 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
17 | 24 | ||
@@ -121,8 +128,8 @@ override_dh_auto_build: | |||
121 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status | 128 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status |
122 | cd build-udeb && ./config.status | 129 | cd build-udeb && ./config.status |
123 | 130 | ||
124 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' | 131 | $(MAKE) -C build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' |
125 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen | 132 | $(MAKE) -C build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen |
126 | 133 | ||
127 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(default_cflags) -Wall -Wl,--as-needed $(default_ldflags)' PKG_CONFIG=$(PKG_CONFIG) | 134 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(default_cflags) -Wall -Wl,--as-needed $(default_ldflags)' PKG_CONFIG=$(PKG_CONFIG) |
128 | 135 | ||