diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 1 | ||||
-rwxr-xr-x | debian/tests/regress | 11 |
2 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog index 0e0e39549..571ff3ccc 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -4,6 +4,7 @@ openssh (1:7.4p1-3) UNRELEASED; urgency=medium | |||
4 | it doesn't seem to help. | 4 | it doesn't seem to help. |
5 | * Run regression tests using 'sh -x' to try to get more information about | 5 | * Run regression tests using 'sh -x' to try to get more information about |
6 | failures. | 6 | failures. |
7 | * Dump some useful log files if regression tests fail. | ||
7 | 8 | ||
8 | -- Colin Watson <cjwatson@debian.org> Sat, 31 Dec 2016 01:22:48 +0000 | 9 | -- Colin Watson <cjwatson@debian.org> Sat, 31 Dec 2016 01:22:48 +0000 |
9 | 10 | ||
diff --git a/debian/tests/regress b/debian/tests/regress index 37f9fe6a2..f3352e3d2 100755 --- a/debian/tests/regress +++ b/debian/tests/regress | |||
@@ -45,6 +45,7 @@ make regress-binaries | |||
45 | 45 | ||
46 | SRCDIR="$(pwd)" | 46 | SRCDIR="$(pwd)" |
47 | BUILDDIR="$SRCDIR" | 47 | BUILDDIR="$SRCDIR" |
48 | ret=0 | ||
48 | make -C regress \ | 49 | make -C regress \ |
49 | .OBJDIR="$BUILDDIR/regress" \ | 50 | .OBJDIR="$BUILDDIR/regress" \ |
50 | .CURDIR="$SRCDIR/regress" \ | 51 | .CURDIR="$SRCDIR/regress" \ |
@@ -58,4 +59,12 @@ make -C regress \ | |||
58 | TEST_SSH_CONCH=conch \ | 59 | TEST_SSH_CONCH=conch \ |
59 | TEST_SSH_IPV6=yes \ | 60 | TEST_SSH_IPV6=yes \ |
60 | TEST_SSH_ECC=yes \ | 61 | TEST_SSH_ECC=yes \ |
61 | tests interop-tests </dev/zero | 62 | tests interop-tests </dev/zero || ret="$?" |
63 | if [ "$ret" -ne 0 ]; then | ||
64 | for log in failed-regress.log failed-ssh.log failed-sshd.log; do | ||
65 | if [ -e "$BUILDDIR/regress/$log" ]; then | ||
66 | tail -v -n+0 "$BUILDDIR/regress/$log" | ||
67 | fi | ||
68 | done | ||
69 | fi | ||
70 | exit "$ret" | ||