diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 7 | ||||
-rw-r--r-- | debian/patches/selinux-setfscreatecon-crash.patch | 28 | ||||
-rw-r--r-- | debian/patches/series | 3 |
3 files changed, 38 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog index ab59d980a..08f22e8b7 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,3 +1,10 @@ | |||
1 | openssh (1:5.7p1-2) UNRELEASED; urgency=low | ||
2 | |||
3 | * Fix crash in ssh_selinux_setfscreatecon when SELinux is disabled | ||
4 | (LP: #708571). | ||
5 | |||
6 | -- Colin Watson <cjwatson@debian.org> Thu, 27 Jan 2011 12:05:26 +0000 | ||
7 | |||
1 | openssh (1:5.7p1-1) experimental; urgency=low | 8 | openssh (1:5.7p1-1) experimental; urgency=low |
2 | 9 | ||
3 | * New upstream release (http://www.openssh.org/txt/release-5.7): | 10 | * New upstream release (http://www.openssh.org/txt/release-5.7): |
diff --git a/debian/patches/selinux-setfscreatecon-crash.patch b/debian/patches/selinux-setfscreatecon-crash.patch new file mode 100644 index 000000000..8d09d3529 --- /dev/null +++ b/debian/patches/selinux-setfscreatecon-crash.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | Description: Fix crash in ssh_selinux_setfscreatecon when SELinux is disabled | ||
2 | Author: Colin Watson <cjwatson@ubuntu.com> | ||
3 | Bug-Ubuntu: https://bugs.launchpad.net/bugs/708571 | ||
4 | Forwarded: https://bugzilla.mindrot.org/show_bug.cgi?id=1851 | ||
5 | Last-Update: 2011-01-27 | ||
6 | |||
7 | Index: b/openbsd-compat/port-linux.c | ||
8 | =================================================================== | ||
9 | --- a/openbsd-compat/port-linux.c | ||
10 | +++ b/openbsd-compat/port-linux.c | ||
11 | @@ -224,12 +224,15 @@ | ||
12 | { | ||
13 | security_context_t context; | ||
14 | |||
15 | + if (!ssh_selinux_enabled()) | ||
16 | + return; | ||
17 | + | ||
18 | if (path == NULL) { | ||
19 | setfscreatecon(NULL); | ||
20 | return; | ||
21 | } | ||
22 | - matchpathcon(path, 0700, &context); | ||
23 | - setfscreatecon(context); | ||
24 | + if (matchpathcon(path, 0700, &context) == 0) | ||
25 | + setfscreatecon(context); | ||
26 | } | ||
27 | |||
28 | #endif /* WITH_SELINUX */ | ||
diff --git a/debian/patches/series b/debian/patches/series index a3431201e..15b5d91db 100644 --- a/debian/patches/series +++ b/debian/patches/series | |||
@@ -39,6 +39,9 @@ doc-hash-tab-completion.patch | |||
39 | # Upstream backports | 39 | # Upstream backports |
40 | selinux-build-failure.patch | 40 | selinux-build-failure.patch |
41 | 41 | ||
42 | # Miscellaneous bug fixes | ||
43 | selinux-setfscreatecon-crash.patch | ||
44 | |||
42 | # Debian-specific configuration | 45 | # Debian-specific configuration |
43 | gnome-ssh-askpass2-icon.patch | 46 | gnome-ssh-askpass2-icon.patch |
44 | debian-config.patch | 47 | debian-config.patch |