diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 9 | ||||
-rw-r--r-- | debian/control | 1 | ||||
-rw-r--r-- | debian/openssh-client-udeb.isinstallable | 10 | ||||
-rwxr-xr-x | debian/rules | 1 |
4 files changed, 21 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog index c77dd2819..a588623bd 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,3 +1,12 @@ | |||
1 | openssh (1:3.8.1p1-6) UNRELEASED; urgency=low | ||
2 | |||
3 | * Implement hack in | ||
4 | http://lists.debian.org/debian-boot/2004/07/msg01207.html to get | ||
5 | openssh-client-udeb to show up as a retrievable debian-installer | ||
6 | component. | ||
7 | |||
8 | -- Colin Watson <cjwatson@debian.org> Mon, 19 Jul 2004 20:22:39 +0100 | ||
9 | |||
1 | openssh (1:3.8.1p1-5) unstable; urgency=medium | 10 | openssh (1:3.8.1p1-5) unstable; urgency=medium |
2 | 11 | ||
3 | * Update German debconf template translation (thanks, Helge Kreutzmann; | 12 | * Update German debconf template translation (thanks, Helge Kreutzmann; |
diff --git a/debian/control b/debian/control index a234348c5..37899eb3c 100644 --- a/debian/control +++ b/debian/control | |||
@@ -51,6 +51,7 @@ Section: debian-installer | |||
51 | Priority: optional | 51 | Priority: optional |
52 | Architecture: any | 52 | Architecture: any |
53 | Depends: ${shlibs:Depends}, libnss-files-udeb | 53 | Depends: ${shlibs:Depends}, libnss-files-udeb |
54 | XB-Installer-Menu-Item: 999 | ||
54 | Description: Secure shell client for the Debian installer | 55 | Description: Secure shell client for the Debian installer |
55 | This is the portable version of OpenSSH, a free implementation of | 56 | This is the portable version of OpenSSH, a free implementation of |
56 | the Secure Shell protocol as specified by the IETF secsh working | 57 | the Secure Shell protocol as specified by the IETF secsh working |
diff --git a/debian/openssh-client-udeb.isinstallable b/debian/openssh-client-udeb.isinstallable new file mode 100644 index 000000000..7591b6245 --- /dev/null +++ b/debian/openssh-client-udeb.isinstallable | |||
@@ -0,0 +1,10 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | # This is a hack to arrange for openssh-client-udeb to show up as a | ||
4 | # retrievable debian-installer component in expert mode (due to the | ||
5 | # Installer-Menu-Item: control field) while not actually appearing on the | ||
6 | # d-i main menu. See: | ||
7 | # | ||
8 | # http://lists.debian.org/debian-boot/2004/07/msg01207.html | ||
9 | |||
10 | exit 1 | ||
diff --git a/debian/rules b/debian/rules index c62447db2..6fdfcc494 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -215,6 +215,7 @@ binary-openssh-client-udeb: build install | |||
215 | dh_compress | 215 | dh_compress |
216 | dh_fixperms | 216 | dh_fixperms |
217 | dh_installdeb | 217 | dh_installdeb |
218 | cp -a debian/openssh-client-udeb.isinstallable debian/openssh-client-udeb/DEBIAN/isinstallable | ||
218 | dh_shlibdeps | 219 | dh_shlibdeps |
219 | dh_gencontrol -- -fdebian/files~ | 220 | dh_gencontrol -- -fdebian/files~ |
220 | dpkg-distaddfile $(CLIENT_UDEB) debian-installer optional | 221 | dpkg-distaddfile $(CLIENT_UDEB) debian-installer optional |