diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 3 | ||||
-rwxr-xr-x | debian/rules | 6 |
2 files changed, 5 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog index 754a70287..ecef13b50 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,5 +1,6 @@ | |||
1 | openssh (1:3.9p1-4) UNRELEASED; urgency=low | 1 | openssh (1:4.0p1-1) UNRELEASED; urgency=low |
2 | 2 | ||
3 | * New upstream release. | ||
3 | * Make gnome-ssh-askpass stay above other windows (thanks, Liyang HU; | 4 | * Make gnome-ssh-askpass stay above other windows (thanks, Liyang HU; |
4 | closes: #296487). | 5 | closes: #296487). |
5 | * Remove obsolete and unnecessary ssh/forward_warning debconf note. | 6 | * Remove obsolete and unnecessary ssh/forward_warning debconf note. |
diff --git a/debian/rules b/debian/rules index bcb28f87f..6a3f31420 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -50,7 +50,7 @@ FORCE_LIBS = LIBS=-lresolv | |||
50 | endif | 50 | endif |
51 | 51 | ||
52 | # Change the version string to include the Debian version | 52 | # Change the version string to include the Debian version |
53 | SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') | 53 | SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') |
54 | 54 | ||
55 | build: build-deb build-udeb | 55 | build: build-deb build-udeb |
56 | 56 | ||
@@ -65,7 +65,7 @@ build-deb-stamp: | |||
65 | # Supply pthread linkage for just those binaries linked to PAM. | 65 | # Supply pthread linkage for just those binaries linked to PAM. |
66 | perl -pi -e 's/^(LIBPAM=.*)/$$1 -pthread/' build-deb/Makefile | 66 | perl -pi -e 's/^(LIBPAM=.*)/$$1 -pthread/' build-deb/Makefile |
67 | 67 | ||
68 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' | 68 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' |
69 | # Support building on Debian 3.0 (with GNOME 1.4) and later. | 69 | # Support building on Debian 3.0 (with GNOME 1.4) and later. |
70 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ | 70 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ |
71 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ | 71 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ |
@@ -83,7 +83,7 @@ build-udeb-stamp: | |||
83 | # Avoid libnsl linkage. Ugh. | 83 | # Avoid libnsl linkage. Ugh. |
84 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status | 84 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status |
85 | cd build-udeb && ./config.status | 85 | cd build-udeb && ./config.status |
86 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh scp sftp sshd ssh-keygen | 86 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh scp sftp sshd ssh-keygen |
87 | touch build-udeb-stamp | 87 | touch build-udeb-stamp |
88 | 88 | ||
89 | clean: | 89 | clean: |