summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBraiden Vasco <braiden-vasco@users.noreply.github.com>2018-04-06 15:51:20 +0000
committerBraiden Vasco <braiden-vasco@users.noreply.github.com>2018-04-06 15:51:20 +0000
commit09478f99578df9d9fd477e0c0b53cb0d74c09e2a (patch)
treedd3eeeaaec0f0e9577987648db69988dbde139ad /CMakeLists.txt
parentd134aecf3ef97009c0884fdfc1c178cf2b9a84b3 (diff)
CMake warn if libconfig not found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ddcf39b6..96795ed3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -544,7 +544,10 @@ if(BOOTSTRAP_DAEMON AND WIN32)
544 set(BOOTSTRAP_DAEMON OFF) 544 set(BOOTSTRAP_DAEMON OFF)
545endif() 545endif()
546if(BOOTSTRAP_DAEMON) 546if(BOOTSTRAP_DAEMON)
547 if(LIBCONFIG_FOUND) 547 if(NOT LIBCONFIG_FOUND)
548 message(WARNING "Option BOOTSTRAP_DAEMON is enabled but required library LIBCONFIG was not found.")
549 set(BOOTSTRAP_DAEMON OFF)
550 else()
548 add_executable(tox-bootstrapd ${CPUFEATURES} 551 add_executable(tox-bootstrapd ${CPUFEATURES}
549 other/bootstrap_daemon/src/command_line_arguments.c 552 other/bootstrap_daemon/src/command_line_arguments.c
550 other/bootstrap_daemon/src/command_line_arguments.h 553 other/bootstrap_daemon/src/command_line_arguments.h