summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzugz (tox) <mbays+tox@sdf.org>2018-12-08 12:32:32 +0100
committerzugz (tox) <mbays+tox@sdf.org>2018-12-11 21:49:34 +0100
commit0f8f82a3cf639233c69c893c102a82b6e11ae98e (patch)
tree8742fec5f6b8d67c755e090fc48cdaa65249c177 /CMakeLists.txt
parent9770880e975a09635a461c46c8fcc193bce57004 (diff)
Add cmake option for building additional tests
Closes #1262
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 18 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c82f8a69..ed4c2191 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -508,18 +508,21 @@ if(NOT WIN32
508 endif() 508 endif()
509endif() 509endif()
510 510
511add_executable(DHT_test ${CPUFEATURES} 511option(BUILD_MISC_TESTS "Build additional tests" OFF)
512 testing/DHT_test.c) 512if (BUILD_MISC_TESTS)
513target_link_modules(DHT_test toxcore misc_tools) 513 add_executable(DHT_test ${CPUFEATURES}
514 514 testing/DHT_test.c)
515add_executable(Messenger_test ${CPUFEATURES} 515 target_link_modules(DHT_test toxcore misc_tools)
516 testing/Messenger_test.c) 516
517target_link_modules(Messenger_test toxcore misc_tools) 517 add_executable(Messenger_test ${CPUFEATURES}
518 518 testing/Messenger_test.c)
519add_executable(random_testing ${CPUFEATURES} 519 target_link_modules(Messenger_test toxcore misc_tools)
520 testing/random_testing.cc) 520
521target_link_modules(random_testing toxcore misc_tools) 521 add_executable(random_testing ${CPUFEATURES}
522 522 testing/random_testing.cc)
523add_executable(save-generator 523 target_link_modules(random_testing toxcore misc_tools)
524 other/fun/save-generator.c) 524
525target_link_modules(save-generator toxcore misc_tools) 525 add_executable(save-generator
526 other/fun/save-generator.c)
527 target_link_modules(save-generator toxcore misc_tools)
528endif()