summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchrono <chron0@users.noreply.github.com>2018-10-06 18:03:52 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-10-07 22:09:54 +0000
commit17a7bf3fd25d5b862b02267843fa2d37ed387d43 (patch)
tree648203637503efef5a9fb2b4dcba5809a4078f10 /CMakeLists.txt
parent3f35a84968f100e1e6d3c9df467fd3c82a9ebb13 (diff)
Add AUTOTEST Option to CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7142af5f..e7c0d79b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -389,8 +389,10 @@ if(ANDROID_CPU_FEATURES)
389 set(CPUFEATURES other/cpufeatures.c) 389 set(CPUFEATURES other/cpufeatures.c)
390endif() 390endif()
391 391
392option(AUTOTEST "Enable autotests (mainly for CI)" OFF)
393
392function(auto_test target) 394function(auto_test target)
393 if(NOT (MSVC AND ARGV1 STREQUAL "MSVC_DONT_BUILD")) 395 if(AUTOTEST AND NOT (MSVC AND ARGV1 STREQUAL "MSVC_DONT_BUILD"))
394 add_executable(auto_${target}_test ${CPUFEATURES} 396 add_executable(auto_${target}_test ${CPUFEATURES}
395 auto_tests/${target}_test.c) 397 auto_tests/${target}_test.c)
396 target_link_modules(auto_${target}_test toxcore misc_tools) 398 target_link_modules(auto_${target}_test toxcore misc_tools)