summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2016-10-06 15:13:47 +0100
committeriphydf <iphydf@users.noreply.github.com>2016-10-11 14:05:41 +0200
commit1ce4c3fe135fe9b018f4d493dce1edcfad33688d (patch)
treeba99a003f5ac877121623fd1188ac37e2e8dac7a /CMakeLists.txt
parentd9f37e4c3342d467920c295031bac58af6b92675 (diff)
Install libraries with RPATH.
This makes deployment easier, as the install libpath is used to look up dependent libraries.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb130ce8..8668312a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
20 20
21include(ApiDsl) 21include(ApiDsl)
22include(CheckCCompilerFlag) 22include(CheckCCompilerFlag)
23include(MacRpath)
23include(ModulePackage) 24include(ModulePackage)
24 25
25set(CMAKE_MACOSX_RPATH ON) 26set(CMAKE_MACOSX_RPATH ON)