summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-10-08 23:33:40 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-10-17 19:25:33 +0000
commit1eaa55d2d4f62e73204d8f68ce05fdebb1ab827c (patch)
treef91c4d444a7810cdd36f4b08ddd7a70caa009fc6 /CMakeLists.txt
parentb6dde3c76ff5382b0dc1caf7323b82e2f9611838 (diff)
Include `CTest` in CMakeLists.txt to get valgrind support.
We can now run `ctest --output-on-failure -D ExperimentalMemCheck -j 50` to run valgrind on all tests.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9db71402..c82f8a69 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,7 @@ message("SOVERSION: ${SOVERSION}")
53################################################################################ 53################################################################################
54 54
55include(ApiDsl) 55include(ApiDsl)
56include(CTest)
56include(ModulePackage) 57include(ModulePackage)
57include(StrictAbi) 58include(StrictAbi)
58include(GNUInstallDirs) 59include(GNUInstallDirs)