summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2020-03-02 20:51:25 +0000
committeriphydf <iphydf@users.noreply.github.com>2020-03-02 21:07:55 +0000
commit28baf9632f545b6c85235ddbb982369d9a4207ca (patch)
treef0d8c00103b9e542c084f00721c12610e98d2ce7 /CMakeLists.txt
parent2dc639a8a4ef0f3c4fc9d4b7c4ebdc79d2d7f702 (diff)
Remove testing/av_test.c.
It's a maintenance burden. Nobody uses this. It depends on an ancient version of opencv that less and less systems actually have.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7043253e..81a41e7f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -492,24 +492,6 @@ endif()
492# 492#
493################################################################################ 493################################################################################
494 494
495option(BUILD_AV_TEST "Build toxav test" ON)
496if(NOT WIN32
497 AND BUILD_AV_TEST AND BUILD_TOXAV
498 AND SNDFILE_FOUND AND PORTAUDIO_FOUND AND OPENCV_FOUND)
499 add_executable(av_test ${CPUFEATURES}
500 testing/av_test.c)
501 target_link_modules(av_test
502 toxcore
503 ${OPENCV_LIBRARIES}
504 ${PORTAUDIO_LIBRARIES}
505 ${SNDFILE_LIBRARIES})
506 # Due to https://github.com/opencv/opencv/issues/6585, we need to compile
507 # av_test as C++ for newer OpenCV versions.
508 if(NOT OPENCV_VERSION VERSION_LESS 3)
509 set_source_files_properties(testing/av_test.c PROPERTIES LANGUAGE CXX)
510 endif()
511endif()
512
513option(BUILD_MISC_TESTS "Build additional tests" OFF) 495option(BUILD_MISC_TESTS "Build additional tests" OFF)
514if (BUILD_MISC_TESTS) 496if (BUILD_MISC_TESTS)
515 add_executable(DHT_test ${CPUFEATURES} 497 add_executable(DHT_test ${CPUFEATURES}