summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorendoffile78 <endoffile78@yahoo.com>2018-08-04 15:56:01 -0500
committeriphydf <iphydf@users.noreply.github.com>2018-08-19 10:38:51 +0000
commit30960dcc7e9661f431d58081d79dc88692bdb50d (patch)
tree56724c62ce9605ec49768b57b16e7333b118310f /CMakeLists.txt
parentfc7a5dc4d80ae065a11fa483e619ead02a88e213 (diff)
Add save file generator, save compatibility test, and generate a save file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5654429..450c224a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -439,6 +439,7 @@ auto_test(tox_one)
439auto_test(tox_strncasecmp) 439auto_test(tox_strncasecmp)
440auto_test(typing) 440auto_test(typing)
441auto_test(version) 441auto_test(version)
442auto_test(save_compatibility)
442 443
443if(BUILD_TOXAV) 444if(BUILD_TOXAV)
444 auto_test(toxav_basic) 445 auto_test(toxav_basic)
@@ -525,3 +526,7 @@ target_link_modules(Messenger_test toxcore misc_tools)
525add_executable(random_testing ${CPUFEATURES} 526add_executable(random_testing ${CPUFEATURES}
526 testing/random_testing.cc) 527 testing/random_testing.cc)
527target_link_modules(random_testing toxcore misc_tools) 528target_link_modules(random_testing toxcore misc_tools)
529
530add_executable(save-generator
531 other/fun/save-generator.c)
532target_link_modules(save-generator toxcore misc_tools)