diff options
author | slvr <slvr@unsafeio.com> | 2013-08-09 16:42:47 +0100 |
---|---|---|
committer | slvr <slvr@unsafeio.com> | 2013-08-09 16:47:16 +0100 |
commit | 4b217bca974e9318aaf2b8d80ccaf1a9a23b2b07 (patch) | |
tree | d324a07283324e43e73325c243d3cfdde3ff424a /CMakeLists.txt | |
parent | 8542b5bac85ec068deac239d46954fa010128cd0 (diff) |
Macports support (OS X only). MAP_ANON -> MAP_ANONYMOUS (OS X only).
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-x | CMakeLists.txt | 8 |
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index c0fea1a1..644e8cc6 100755 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -10,6 +10,14 @@ else() | |||
10 | option(USE_NACL "Use NaCl library instead of libsodium") | 10 | option(USE_NACL "Use NaCl library instead of libsodium") |
11 | endif() | 11 | endif() |
12 | 12 | ||
13 | #OS X specific | ||
14 | if(APPLE) | ||
15 | set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /opt/local/lib) | ||
16 | set(CMAKE_INCLUDE_PATH ${CMAKE_INCLUDE_PATH} /opt/local/include) | ||
17 | set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -I/opt/local/include" ) | ||
18 | set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -L/opt/local/lib") | ||
19 | endif() | ||
20 | |||
13 | if(UNIX) | 21 | if(UNIX) |
14 | find_package(Curses REQUIRED) | 22 | find_package(Curses REQUIRED) |
15 | endif() | 23 | endif() |