summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-01-29 22:14:21 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-01-29 22:14:21 +0000
commit6f6c4dc2bd8820e6bccb9353ad42c951dc7adcd4 (patch)
treeaeaf9bda957933f95b017c9dfeb0ea28053b8dfc /CMakeLists.txt
parent6e0ac337c979af420bef197f2a9e2bde5e65d0fc (diff)
Add `-D__STDC_LIMIT_MACROS=1` for C++ code.
Without this, `UINT*_MAX` are not defined.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d7fcece..958f42ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -467,6 +467,7 @@ function(auto_test target)
467endfunction() 467endfunction()
468 468
469if(BUILD_TOXAV) 469if(BUILD_TOXAV)
470 add_definitions(-D__STDC_LIMIT_MACROS=1)
470 add_executable(auto_monolith_test 471 add_executable(auto_monolith_test
471 auto_tests/monolith_test.cpp 472 auto_tests/monolith_test.cpp
472 ${ANDROID_CPU_FEATURES}) 473 ${ANDROID_CPU_FEATURES})