summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-06-25 12:37:46 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-06-29 23:24:20 +0000
commit706fad1ce88c2104009a3835ee343ff9d8ec8b79 (patch)
treeb2c0d8ccb434515cbbd4e0c9e86ce21f099c11a7 /CMakeLists.txt
parent52f21e32518244f3008efbef073f9d3ac9e68b43 (diff)
Add a test to try and overflow the send queue in net_crypto.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd05ad70..cc55a235 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -492,6 +492,7 @@ auto_test(crypto MSVC_DONT_BUILD)
492auto_test(dht MSVC_DONT_BUILD) 492auto_test(dht MSVC_DONT_BUILD)
493auto_test(encryptsave) 493auto_test(encryptsave)
494auto_test(file_transfer) 494auto_test(file_transfer)
495auto_test(friend_connection)
495auto_test(friend_request) 496auto_test(friend_request)
496auto_test(invalid_proxy) 497auto_test(invalid_proxy)
497auto_test(invalid_tcp_proxy) 498auto_test(invalid_tcp_proxy)
@@ -501,6 +502,8 @@ auto_test(lossy_packet)
501auto_test(messenger MSVC_DONT_BUILD) 502auto_test(messenger MSVC_DONT_BUILD)
502auto_test(network) 503auto_test(network)
503auto_test(onion) 504auto_test(onion)
505auto_test(overflow_recvq)
506auto_test(overflow_sendq)
504auto_test(save_friend) 507auto_test(save_friend)
505auto_test(save_load) 508auto_test(save_load)
506auto_test(send_message) 509auto_test(send_message)