summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2016-08-19 19:31:08 +0100
committeriphydf <iphydf@users.noreply.github.com>2016-08-24 09:41:40 +0100
commit7075c3648aa125e21118a3e7aa38594d03bfb296 (patch)
treeef2fea5260076e9ba844885017ae0814dc0e4210 /CMakeLists.txt
parent503d198741e592bb0272fb2a637b1379ed844dfa (diff)
Add cmake test for apidsl.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25c8ed15..9061286d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -223,6 +223,9 @@ target_link_libraries(toxencryptsave toxcore)
223# 223#
224################################################################################ 224################################################################################
225 225
226add_test(format_test
227 ${CMAKE_SOURCE_DIR}/other/astyle/format-source "${CMAKE_SOURCE_DIR}")
228
226function(auto_test target) 229function(auto_test target)
227 if(CHECK_FOUND) 230 if(CHECK_FOUND)
228 add_executable(auto_${target} auto_tests/${target}.c) 231 add_executable(auto_${target} auto_tests/${target}.c)