summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorslvr <slvr@unsafeio.com>2013-08-09 16:42:47 +0100
committerslvr <slvr@unsafeio.com>2013-08-09 16:51:54 +0100
commit91d8344ccaae57d2860040a2c8665d67639cf8d6 (patch)
tree2479fb09e7be2711e53a65bf5fab0540830298c0 /CMakeLists.txt
parent8542b5bac85ec068deac239d46954fa010128cd0 (diff)
Macports support (OS X only). MAP_ANON -> MAP_ANONYMOUS (OS X only).
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0fea1a1..86b5d27b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,14 @@ else()
10 option(USE_NACL "Use NaCl library instead of libsodium") 10 option(USE_NACL "Use NaCl library instead of libsodium")
11endif() 11endif()
12 12
13#OS X specific
14if(APPLE)
15 set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /opt/local/lib)
16 set(CMAKE_INCLUDE_PATH ${CMAKE_INCLUDE_PATH} /opt/local/include)
17 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -I/opt/local/include" )
18 set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -L/opt/local/lib")
19endif()
20
13if(UNIX) 21if(UNIX)
14 find_package(Curses REQUIRED) 22 find_package(Curses REQUIRED)
15endif() 23endif()