summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-03-17 14:48:34 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-03-17 15:04:03 +0000
commit9706d9a0f015a58937255abd95101045ab865796 (patch)
treef80d6558912e09b22b4f0c44440e54f92fd40cae /CMakeLists.txt
parenta2496af71aeed3cd7324fb59d9f32c2d52759d56 (diff)
Disallow stderr logger by default.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f18988c..21182d33 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -192,6 +192,11 @@ if(NOT USE_IPV6)
192 add_definitions(-DUSE_IPV6=0) 192 add_definitions(-DUSE_IPV6=0)
193endif() 193endif()
194 194
195option(USE_STDERR_LOGGER "Enable logging to stderr when the logger is NULL" OFF)
196if(USE_STDERR_LOGGER)
197 add_definitions(-DUSE_STDERR_LOGGER=1)
198endif()
199
195option(BUILD_TOXAV "Whether to build the tox AV library" ON) 200option(BUILD_TOXAV "Whether to build the tox AV library" ON)
196option(MUST_BUILD_TOXAV "Fail the build if toxav cannot be built" OFF) 201option(MUST_BUILD_TOXAV "Fail the build if toxav cannot be built" OFF)
197 202