summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-07-08 08:43:42 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-07-09 21:04:50 +0000
commitabc17b0f8997ab07ae66130edd5dc8c43e72c886 (patch)
tree88056839c808a9f7f8c58f55ebe273aa7b5facdb /CMakeLists.txt
parent4e21c065517d6e125cb1d1b9a13e886b3046b0d8 (diff)
Factor out time keeping code into its own module: mono_time.c.
It turns out, `unix_time` is also monotonic, and is used as such, so I've renamed the new functions to `mono_time_*`. 2018-07-08: ``` 00:01 <@irungentoo> the idea used to be that the unix_time() function could go backward in time but I think I might have started using it like if it could not after I changed it so that it would never go back in time ```
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3266e2f..9fe1c3c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,6 +171,8 @@ set(toxcore_PKGCONFIG_REQUIRES ${toxcore_PKGCONFIG_REQUIRES} libsodium)
171set(toxcore_SOURCES ${toxcore_SOURCES} 171set(toxcore_SOURCES ${toxcore_SOURCES}
172 toxcore/logger.c 172 toxcore/logger.c
173 toxcore/logger.h 173 toxcore/logger.h
174 toxcore/mono_time.c
175 toxcore/mono_time.h
174 toxcore/network.c 176 toxcore/network.c
175 toxcore/network.h 177 toxcore/network.h
176 toxcore/state.c 178 toxcore/state.c
@@ -343,6 +345,7 @@ include(CompileGTest)
343unit_test(toxav ring_buffer) 345unit_test(toxav ring_buffer)
344unit_test(toxav rtp) 346unit_test(toxav rtp)
345unit_test(toxcore crypto_core) 347unit_test(toxcore crypto_core)
348unit_test(toxcore mono_time)
346unit_test(toxcore util) 349unit_test(toxcore util)
347 350
348################################################################################ 351################################################################################