summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-02-19 00:09:49 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-02-19 21:00:19 +0000
commitc4a734e30462d59d7f9bfe4a865b33936907e0d5 (patch)
tree1066d8802a0889de0c0fd920e5b848968c386084 /CMakeLists.txt
parent097f41f26467249a9b3016dde9151871ae0de501 (diff)
Remove apidsl from the build.
apidsl is in feature freeze. We can rely on the web service, instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e438e221..1aee8017 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -399,16 +399,15 @@ set(TEST_TIMEOUT_SECONDS "" CACHE STRING "Limit runtime of each test to the numb
399 399
400option(FORMAT_TEST "Require the format_test to be executed; fail cmake if it can't" OFF) 400option(FORMAT_TEST "Require the format_test to be executed; fail cmake if it can't" OFF)
401 401
402if(APIDSL AND ASTYLE) 402if(ASTYLE)
403 add_test( 403 add_test(
404 NAME format_test 404 NAME format_test
405 COMMAND ${toxcore_SOURCE_DIR}/other/astyle/format-source 405 COMMAND ${toxcore_SOURCE_DIR}/other/astyle/format-source
406 "${toxcore_SOURCE_DIR}" 406 "${toxcore_SOURCE_DIR}"
407 "${APIDSL}"
408 "${ASTYLE}") 407 "${ASTYLE}")
409 set_tests_properties(format_test PROPERTIES TIMEOUT "${TEST_TIMEOUT_SECONDS}") 408 set_tests_properties(format_test PROPERTIES TIMEOUT "${TEST_TIMEOUT_SECONDS}")
410elseif(FORMAT_TEST) 409elseif(FORMAT_TEST)
411 message(FATAL_ERROR "format_test can not be run, because either APIDSL (${APIDSL}) or ASTYLE (${ASTYLE}) could not be found") 410 message(FATAL_ERROR "format_test can not be run, because ASTYLE (${ASTYLE}) could not be found")
412endif() 411endif()
413 412
414function(auto_test target) 413function(auto_test target)