summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMaxim Biro <nurupo.contributions@gmail.com>2017-03-04 03:39:31 -0500
committerMaxim Biro <nurupo.contributions@gmail.com>2018-01-25 17:27:26 -0500
commitc9ed0ae8cdb73ab12c6f52c78c55888420f069fd (patch)
treec172f7f5970feaa81c9a1266fe68fc842a6618e5 /CMakeLists.txt
parent6df9e05da2ffca5fa8cc9601d86765b759ed8f99 (diff)
Show source file name and line number on crash
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4544a91a..2d7fcece 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,10 @@ if(NOT "${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
83 if(DEBUG) 83 if(DEBUG)
84 set(MIN_LOGGER_LEVEL DEBUG) 84 set(MIN_LOGGER_LEVEL DEBUG)
85 add_cflag("-g3") 85 add_cflag("-g3")
86 if(MINGW)
87 # Allows wine to display source code file names and line numbers on crash in its backtrace
88 add_flag("-gdwarf-2")
89 endif()
86 endif() 90 endif()
87 91
88 option(WARNINGS "Enable additional compiler warnings" ON) 92 option(WARNINGS "Enable additional compiler warnings" ON)