summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-06-25 15:13:15 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-06-25 19:48:11 +0000
commitd22332dd505b5a269d379863a091d74522fce27b (patch)
tree8099f079ff87e245f8a0765e5d554253d38bf397 /CMakeLists.txt
parent7684b5ae3eaabec8fac035752fff30c651109dfc (diff)
Remove the format test.
It's annoying to have a test touch every source file. It causes a recompile of everything after every test run.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7147d07b..875d0a28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -450,19 +450,6 @@ unit_test(toxcore util)
450 450
451set(TEST_TIMEOUT_SECONDS "" CACHE STRING "Limit runtime of each test to the number of seconds specified") 451set(TEST_TIMEOUT_SECONDS "" CACHE STRING "Limit runtime of each test to the number of seconds specified")
452 452
453option(FORMAT_TEST "Require the format_test to be executed; fail cmake if it can't" OFF)
454
455if(ASTYLE)
456 add_test(
457 NAME format_test
458 COMMAND ${toxcore_SOURCE_DIR}/other/astyle/format-source
459 "${toxcore_SOURCE_DIR}"
460 "${ASTYLE}")
461 set_tests_properties(format_test PROPERTIES TIMEOUT "${TEST_TIMEOUT_SECONDS}")
462elseif(FORMAT_TEST)
463 message(FATAL_ERROR "format_test can not be run, because ASTYLE (${ASTYLE}) could not be found")
464endif()
465
466if(ANDROID_CPU_FEATURES) 453if(ANDROID_CPU_FEATURES)
467 # We need to compile cpufeatures.c as many times as there are executables, 454 # We need to compile cpufeatures.c as many times as there are executables,
468 # because libvpx doesn't include it although it depends on it. We can't get 455 # because libvpx doesn't include it although it depends on it. We can't get