summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-01-14 01:06:49 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-01-14 19:30:05 +0000
commitd79b15c52daf82748040f41f93fa6e046efdeee7 (patch)
tree9d2e84a4616c17a91b9f48dcf7731e9dcd816571 /CMakeLists.txt
parent1eea3f0ab6fbccac3f276b7db7101ed57e6986ba (diff)
Use apidsl to generate ping.h.
The ping.api.h file looks rather ugly, but it works. This is an exercise in finding the complete set of use cases needed from apidsl for toxcore. We'll try to make things work as much as possible, and then make apidsl better and make the .api.h files pretty.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f164dad..bc846554 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,6 +228,7 @@ endif()
228 228
229# LAYER 3: Distributed Hash Table 229# LAYER 3: Distributed Hash Table
230# ------------------------------- 230# -------------------------------
231apidsl(toxcore/ping.api.h)
231apidsl(toxcore/ping_array.api.h) 232apidsl(toxcore/ping_array.api.h)
232add_submodule(toxcore toxdht 233add_submodule(toxcore toxdht
233 toxcore/DHT.c 234 toxcore/DHT.c