summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2016-12-05 22:00:05 +0000
committeriphydf <iphydf@users.noreply.github.com>2016-12-05 22:02:30 +0000
commitd8ae726d0a332c74da7bbed70982367dd01899e1 (patch)
tree9a60aa519c6f4cf98e17c0bda703b07fbde1caf4 /CMakeLists.txt
parentd66b3eabd5a243d8389dcdb9a091f1d4814315d2 (diff)
Don't build nTox by default.
Build it on Travis. It won't be built on the windows builds regardless of having it enabled globally. Fixes #292.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49db1cf2..7dc9d20c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -483,8 +483,8 @@ if(NOT WIN32
483 endif() 483 endif()
484endif() 484endif()
485 485
486option(BUILD_NTOX "Build nTox client" ON) 486option(BUILD_NTOX "Build nTox client" OFF)
487if(NOT WIN32 AND BUILD_NTOX) 487if(BUILD_NTOX AND NOT WIN32)
488 add_c_executable(nTox testing/nTox.c) 488 add_c_executable(nTox testing/nTox.c)
489 target_link_modules(nTox toxcore ${NCURSES_LIBRARIES}) 489 target_link_modules(nTox toxcore ${NCURSES_LIBRARIES})
490endif() 490endif()