diff options
author | Sean Qureshi <stqism@risingstormgames.com> | 2013-08-03 11:41:47 -0700 |
---|---|---|
committer | Sean Qureshi <stqism@risingstormgames.com> | 2013-08-03 11:41:47 -0700 |
commit | e4d63c63c7ee02f144e7f061cbe3e5f631ad95d8 (patch) | |
tree | e6f489c867bf90b2a187fe55556ddc2b4a348a1c /CMakeLists.txt | |
parent | 86d7734efea1e7f345a9635f78bbf055116f8d84 (diff) | |
parent | 7b84aaaac8005a6bf2a1243a2fb027f6d9a8cf9d (diff) |
Merge branch 'master' of https://github.com/irungentoo/ProjectTox-Core
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-x | CMakeLists.txt | 10 |
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index bf709e72..07098391 100755 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -2,6 +2,10 @@ cmake_minimum_required(VERSION 2.6.0) | |||
2 | 2 | ||
3 | set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake) | 3 | set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake) |
4 | 4 | ||
5 | if(UNIX) | ||
6 | find_package(Curses REQUIRED) | ||
7 | endif() | ||
8 | |||
5 | if(NOT WIN32) | 9 | if(NOT WIN32) |
6 | option(USE_NACL "Use NaCl library instead of libsodium") | 10 | option(USE_NACL "Use NaCl library instead of libsodium") |
7 | endif() | 11 | endif() |
@@ -29,15 +33,15 @@ if(NOT USE_NACL) | |||
29 | endif() | 33 | endif() |
30 | 34 | ||
31 | macro(linkCoreLibraries exe_name) | 35 | macro(linkCoreLibraries exe_name) |
32 | add_dependencies(${exe_name} core) | 36 | add_dependencies(${exe_name} toxcore) |
33 | if(WIN32) | 37 | if(WIN32) |
34 | include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/) | 38 | include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/) |
35 | target_link_libraries(${exe_name} core | 39 | target_link_libraries(${exe_name} toxcore |
36 | ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a | 40 | ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a |
37 | ws2_32) | 41 | ws2_32) |
38 | else() | 42 | else() |
39 | include_directories(${SODIUM_INCLUDE_DIR}) | 43 | include_directories(${SODIUM_INCLUDE_DIR}) |
40 | target_link_libraries(${exe_name} core | 44 | target_link_libraries(${exe_name} toxcore |
41 | ${LINK_CRYPTO_LIBRARY}) | 45 | ${LINK_CRYPTO_LIBRARY}) |
42 | 46 | ||
43 | endif() | 47 | endif() |