summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-07-17 01:18:04 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-07-22 02:34:30 +0000
commitf627a26a7b1c3619ba66f84b87092ff8ba7a95b6 (patch)
treec72c950fab473dc9bec4b5329d251b790e55443d /CMakeLists.txt
parent7245ac11ef9be2420c8356c12acc79f93ea211bb (diff)
Run Clang global static analysis on Travis.
This uses a single .cc file containing almost all the code in the repository to perform whole program analysis.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 181d4155..92c7beb9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,7 +104,7 @@ if(TRACE)
104endif() 104endif()
105 105
106if(MIN_LOGGER_LEVEL) 106if(MIN_LOGGER_LEVEL)
107 add_definitions(-DMIN_LOGGER_LEVEL=LOG_${MIN_LOGGER_LEVEL}) 107 add_definitions(-DMIN_LOGGER_LEVEL=LOGGER_LEVEL_${MIN_LOGGER_LEVEL})
108endif() 108endif()
109 109
110option(USE_IPV6 "Use IPv6 in tests" ON) 110option(USE_IPV6 "Use IPv6 in tests" ON)
@@ -403,14 +403,6 @@ function(auto_test target)
403 endif() 403 endif()
404endfunction() 404endfunction()
405 405
406if(BUILD_TOXAV)
407 add_definitions(-D__STDC_LIMIT_MACROS=1)
408 add_executable(auto_monolith_test ${CPUFEATURES}
409 auto_tests/monolith_test.cc)
410 target_link_libraries(auto_monolith_test ${toxcore_LINK_MODULES})
411 add_test(NAME monolith COMMAND ${CROSSCOMPILING_EMULATOR} auto_monolith_test)
412endif()
413
414auto_test(TCP) 406auto_test(TCP)
415auto_test(bootstrap) 407auto_test(bootstrap)
416auto_test(conference) 408auto_test(conference)