summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2016-08-30 17:50:59 +0100
committeriphydf <iphydf@users.noreply.github.com>2016-08-30 19:31:40 +0100
commitfa3b51266bdc13a6b5fafdc2518f89b03e5f084f (patch)
tree582c9e7a2ca197aab4fc90b1ec26821ae1765e30 /CMakeLists.txt
parent4692cea75e82d05c4facf97c8853819281f376cf (diff)
Add missing #includes to headers and rename tox_old to tox_group.
Also, no longer #include the group code into tox.c. Instead, compile it separately in tox_group.c. This is a bit less surprising to someone looking around the code. Having some implementations in a .h file is certainly a bit surprising to a disciplined C programmer, especially when there is no technical reason to do it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c716f825..0db88621 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,7 +173,8 @@ target_link_libraries(toxgroup toxmessenger)
173# LAYER 8: Public API 173# LAYER 8: Public API
174# ------------------- 174# -------------------
175add_library(toxcore ${LIBTYPE} 175add_library(toxcore ${LIBTYPE}
176 toxcore/tox.c) 176 toxcore/tox.c
177 toxcore/tox_group.c)
177target_link_libraries(toxcore toxgroup) 178target_link_libraries(toxcore toxgroup)
178 179
179 180
@@ -365,7 +366,7 @@ install(TARGETS
365install(FILES 366install(FILES
366 toxav/toxav.h 367 toxav/toxav.h
367 toxcore/tox.h 368 toxcore/tox.h
368 toxcore/tox_old.h 369 toxcore/tox_group.h
369 toxdns/toxdns.h 370 toxdns/toxdns.h
370 toxencryptsave/toxencryptsave.h 371 toxencryptsave/toxencryptsave.h
371 DESTINATION "include/tox") 372 DESTINATION "include/tox")