summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorjin-eld <jin at mediatomb dot cc>2013-08-13 21:55:32 +0300
committerjin-eld <jin at mediatomb dot cc>2013-08-24 03:25:07 +0300
commit50c8a820e5ab46acc129a49ab849f8848e40d915 (patch)
tree4eb66794fd31fd96cf0ac0c6cbb01bca5e122283 /Makefile.am
parente658892793c42b2d058eed0937025ef2ddaaa372 (diff)
Implemented autotools based build scripts
supported options: --with-dependency-search=DIR will tell configure to look for various dependencies in DIR/include and DIR/lib Alternatively you can also specify libsodium header and libs location with --with-libsodium-headers and --with-libsodium-libs if it is installed elsewhere. Ncurses and libconfig are handled via the default pkg-config way, see ./configure --help=short for detailed information. The tox library is compiled as libtoxcore in shared and static variants, public headers are installed to ${prefix}/include/tox A pkg-config libtoxcore.pc configuration file is provided. Use ./configure --help for a full list of configure options or ./configure --help=short for the options that I added. To generate the configure script after pulling from git use: autoreconf -i To generate a release tarball use: make dist Unit tests are handled by the libcheck library integration that is provided by autotools, use: make check to compile and run the tests. Unit tests are currently optional, i.e. - if the check library is not found on the system, then tests will be disabled. Same goes for nTox and DHT bootstrap daemon - they will be enabled or disabled depending on the availability of ncurses (for nTox) or libconfig (for DHT bootstrap daemon). The above can be also tuned by: --enable-tests / --disable-tests --enable-ntox / --disable-ntox --enable-dht-bootstrap-daemon / --disable-dht-bootstrap-daemon
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..7bead885
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
1SUBDIRS = build
2
3ACLOCAL_AMFLAGS = -I m4
4
5pkgconfigdir = $(libdir)/pkgconfig
6pkgconfig_DATA = $(top_srcdir)/libtoxcore.pc
7
8BUILT_SOURCES = $(top_srcdir)/libtoxcore.pc
9CLEANFILES = $(top_srcdir)/libtoxcore.pc
10
11
12EXTRA_DIST = \
13 $(top_srcdir)/libtoxcore.pc.in \
14 $(top_srcdir)/cmake/FindCheck.cmake \
15 $(top_srcdir)/cmake/FindLIBCONFIG.cmake \
16 $(top_srcdir)/cmake/FindSphinx.cmake \
17 $(top_srcdir)/cmake/FindSODIUM.cmake \
18 $(top_srcdir)/cmake/FindNaCl.cmake \
19 $(top_srcdir)/cmake/FindCursesw.cmake \
20 $(top_srcdir)/docs/CMakeLists.txt \
21 $(top_srcdir)/docs/commands.rst \
22 $(top_srcdir)/docs/conf.py.in \
23 $(top_srcdir)/docs/index.rst \
24 $(top_srcdir)/docs/install.rst \
25 $(top_srcdir)/docs/start_guide.de.rst \
26 $(top_srcdir)/docs/start_guide.rst \
27 $(top_srcdir)/CMakeLists.txt \
28 $(top_srcdir)/tools/README \
29 $(top_srcdir)/tools/astylerc \
30 $(top_srcdir)/tools/pre-commit
31