summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormannol <eniz_vukovic@hotmail.com>2014-05-03 01:46:03 +0200
committermannol <eniz_vukovic@hotmail.com>2014-05-03 01:46:03 +0200
commit0fa03b924030c5791599451389ba84b81be84da8 (patch)
tree0d3b93baeb3c18b2f1afce5b9455c9b8bd21ec89 /configure.ac
parent42b25a4d3e2fe66f03cbd8c866d8af7bd4f6e5a7 (diff)
Bunch of random changes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac93
1 files changed, 0 insertions, 93 deletions
diff --git a/configure.ac b/configure.ac
index f82f0a19..8650e197 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,6 @@ BUILD_DHT_BOOTSTRAP_DAEMON="no"
31BUILD_NTOX="no" 31BUILD_NTOX="no"
32BUILD_TESTS="yes" 32BUILD_TESTS="yes"
33BUILD_AV="yes" 33BUILD_AV="yes"
34BUILD_PHONE="no"
35BUILD_TESTING="yes" 34BUILD_TESTING="yes"
36 35
37LOGGING="no" 36LOGGING="no"
@@ -135,23 +134,11 @@ AC_ARG_WITH(logger-path,
135 134
136PKG_PROG_PKG_CONFIG 135PKG_PROG_PKG_CONFIG
137 136
138AC_ARG_ENABLE([phone],
139 [AC_HELP_STRING([--enable-phone], [build test phone (default: auto)]) ],
140 [
141 if test "x$enableval" = "xno"; then
142 BUILD_PHONE="no"
143 elif test "x$enableval" = "xyes"; then
144 BUILD_PHONE="yes"
145 fi
146 ]
147)
148
149AC_ARG_ENABLE([av], 137AC_ARG_ENABLE([av],
150 [AC_HELP_STRING([--disable-av], [build AV support libraries (default: auto)]) ], 138 [AC_HELP_STRING([--disable-av], [build AV support libraries (default: auto)]) ],
151 [ 139 [
152 if test "x$enableval" = "xno"; then 140 if test "x$enableval" = "xno"; then
153 BUILD_AV="no" 141 BUILD_AV="no"
154 BUILD_PHONE="no"
155 elif test "x$enableval" = "xyes"; then 142 elif test "x$enableval" = "xyes"; then
156 BUILD_AV="yes" 143 BUILD_AV="yes"
157 fi 144 fi
@@ -447,94 +434,16 @@ if test "x$BUILD_AV" = "xyes"; then
447 [ 434 [
448 AC_MSG_WARN([disabling AV support: required pthread library not found]) 435 AC_MSG_WARN([disabling AV support: required pthread library not found])
449 BUILD_AV="no" 436 BUILD_AV="no"
450 BUILD_PHONE="no"
451 ]
452 )
453fi
454
455if test "x$BUILD_PHONE" = "xyes"; then
456 PKG_CHECK_MODULES([AVFORMAT], [libavformat],
457 [],
458 [
459 AC_MSG_WARN([disabling phone $AVFORMAT_PKG_ERRORS])
460 BUILD_PHONE="no"
461 ] 437 ]
462 ) 438 )
463fi 439fi
464 440
465if test "x$BUILD_PHONE" = "xyes"; then
466 PKG_CHECK_MODULES([AVCODEC], [libavcodec],
467 [],
468 [
469 AC_MSG_WARN([disabling phone $AVCODEC_PKG_ERRORS])
470 BUILD_PHONE="no"
471 ]
472 )
473fi
474
475if test "x$BUILD_PHONE" = "xyes"; then
476 PKG_CHECK_MODULES([AVUTIL], [libavutil],
477 [],
478 [
479 AC_MSG_WARN([disabling phone $AVUTIL_PKG_ERRORS])
480 BUILD_PHONE="no"
481 ]
482 )
483fi
484
485if test "x$BUILD_PHONE" = "xyes"; then
486 PKG_CHECK_MODULES([AVDEVICE], [libavdevice],
487 [],
488 [
489 AC_MSG_WARN([disabling phone $AVDEVICE_PKG_ERRORS])
490 BUILD_PHONE="no"
491 ]
492 )
493fi
494
495if test "x$BUILD_PHONE" = "xyes"; then
496 PKG_CHECK_MODULES([SWSCALE], [libswscale],
497 [],
498 [
499 AC_MSG_WARN([disabling phone $SWSCALE_PKG_ERRORS])
500 BUILD_PHONE="no"
501 ]
502 )
503fi
504
505if test "x$BUILD_PHONE" = "xyes"; then
506 PKG_CHECK_MODULES([SDL], [sdl],
507 [],
508 [
509 AC_MSG_WARN([disabling phone $SDL_PKG_ERRORS])
510 BUILD_PHONE="no"
511 ]
512 )
513fi
514
515if test "x$BUILD_PHONE" = "xyes"; then
516 PKG_CHECK_MODULES([OPENAL], [openal],
517 [],
518 [
519 AC_MSG_WARN([disabling phone $OPENAL_PKG_ERRORS])
520 BUILD_PHONE="no"
521 ]
522 )
523fi
524
525#If all dependencies are here add support video define for phone.c
526if test "x$BUILD_PHONE" == "xyes"; then
527 #Set FFMpeg define
528 AC_DEFINE([TOX_FFMPEG], [1], [Support video])
529fi
530
531if test "x$BUILD_AV" = "xyes"; then 441if test "x$BUILD_AV" = "xyes"; then
532 PKG_CHECK_MODULES([OPUS], [opus], 442 PKG_CHECK_MODULES([OPUS], [opus],
533 [], 443 [],
534 [ 444 [
535 AC_MSG_WARN([disabling AV support $OPUS_PKG_ERRORS]) 445 AC_MSG_WARN([disabling AV support $OPUS_PKG_ERRORS])
536 BUILD_AV="no" 446 BUILD_AV="no"
537 BUILD_PHONE="no"
538 ] 447 ]
539 ) 448 )
540fi 449fi
@@ -545,7 +454,6 @@ if test "x$BUILD_AV" = "xyes"; then
545 [ 454 [
546 AC_MSG_WARN([disabling AV support $VPX_PKG_ERRORS]) 455 AC_MSG_WARN([disabling AV support $VPX_PKG_ERRORS])
547 BUILD_AV="no" 456 BUILD_AV="no"
548 BUILD_PHONE="no"
549 ] 457 ]
550 ) 458 )
551fi 459fi
@@ -719,7 +627,6 @@ AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP_DAEMON, test "x$BUILD_DHT_BOOTSTRAP_DAEMON" =
719AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes") 627AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes")
720AM_CONDITIONAL(BUILD_NTOX, test "x$BUILD_NTOX" = "xyes") 628AM_CONDITIONAL(BUILD_NTOX, test "x$BUILD_NTOX" = "xyes")
721AM_CONDITIONAL(BUILD_AV, test "x$BUILD_AV" = "xyes") 629AM_CONDITIONAL(BUILD_AV, test "x$BUILD_AV" = "xyes")
722AM_CONDITIONAL(BUILD_PHONE, test "x$BUILD_PHONE" = "xyes")
723AM_CONDITIONAL(BUILD_TESTING, test "x$BUILD_TESTING" = "xyes") 630AM_CONDITIONAL(BUILD_TESTING, test "x$BUILD_TESTING" = "xyes")
724AM_CONDITIONAL(WIN32, test "x$WIN32" = "xyes") 631AM_CONDITIONAL(WIN32, test "x$WIN32" = "xyes")
725 632