summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorirungentoo <irungentoo@gmail.com>2014-06-12 11:15:20 -0400
committerirungentoo <irungentoo@gmail.com>2014-06-12 11:15:20 -0400
commit2740099da010846fdb38883ae74cff31b014ca61 (patch)
tree8c50566344c486d7e3d0ae2196cac123ec56e75f /configure.ac
parent4f2674eb0f5b5d12177bb3638dbe60ceed0d5e57 (diff)
pthread is now a core dependency instead of just a toxav dependency.
Fixed possible thread bug with sending A/V packets. TODO: eventually make toxcore thread safe.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 7 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index e3b9a77b..0dd88da4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -459,15 +459,13 @@ if (test "x$WIN32" != "xyes") && (test "x$MACH" != "xyes") && (test "x$DISABLE_R
459 ) 459 )
460fi 460fi
461 461
462if test "x$BUILD_AV" = "xyes"; then 462
463 AX_PTHREAD( 463AX_PTHREAD(
464 [], 464 [],
465 [ 465 [
466 AC_MSG_WARN([disabling AV support: required pthread library not found]) 466 AC_MSG_ERROR([required library pthread was not found on your system])
467 BUILD_AV="no" 467 ]
468 ] 468)
469 )
470fi
471 469
472if test "x$BUILD_AV" = "xyes"; then 470if test "x$BUILD_AV" = "xyes"; then
473 PKG_CHECK_MODULES([OPUS], [opus], 471 PKG_CHECK_MODULES([OPUS], [opus],