summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-02-05 21:38:58 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-02-09 20:51:39 +0000
commit6cd4fcdec4e6671e63e8c7cba2ab4c6d594b13fd (patch)
tree09485be8361d503f1acdee57055535a6b3331d17 /configure.ac
parent05912fd65c52f97a600383be11cd741ae32d61bf (diff)
Remove libcheck from the dependencies.
We're not gaining much from this library, and it's a burden, especially for windows development.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 18796bdd..e094489f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,6 @@ TOX_LOGGER="no"
26 26
27NCURSES_FOUND="no" 27NCURSES_FOUND="no"
28LIBCONFIG_FOUND="no" 28LIBCONFIG_FOUND="no"
29LIBCHECK_FOUND="no"
30WANT_NACL="no" 29WANT_NACL="no"
31ADD_NACL_OBJECTS_TO_PKGCONFIG="yes" 30ADD_NACL_OBJECTS_TO_PKGCONFIG="yes"
32SET_SO_VERSION="yes" 31SET_SO_VERSION="yes"
@@ -525,17 +524,6 @@ if test "x$BUILD_AV" = "xyes"; then
525fi 524fi
526 525
527if test -n "$PKG_CONFIG"; then 526if test -n "$PKG_CONFIG"; then
528 if test "x$BUILD_TESTS" = "xyes"; then
529 PKG_CHECK_MODULES([CHECK], [check],
530 [
531 LIBCHECK_FOUND="yes"
532 ],
533 [
534 AC_MSG_WARN([libcheck not found, not building unit tests: $CHECK_PKG_ERRORS])
535 BUILD_TESTS="no"
536 ])
537 fi
538
539 if test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes"; then 527 if test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes"; then
540 PKG_CHECK_MODULES([LIBCONFIG], [libconfig >= 1.4.6], 528 PKG_CHECK_MODULES([LIBCONFIG], [libconfig >= 1.4.6],
541 [ 529 [
@@ -572,26 +560,6 @@ if (test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes") && \
572 fi 560 fi
573fi 561fi
574 562
575if (test "x$BUILD_TESTS" = "xyes") && (test "x$LIBCHECK_FOUND" = "xno"); then
576 AC_CHECK_HEADER([check.h],
577 [],
578 [
579 AC_MSG_WARN([header file for check library was not found on your system, unit tests will be disabled])
580 BUILD_TESTS="no"
581 ]
582 )
583
584 if test "x$BUILD_TESTS" = "xyes"; then
585 AC_CHECK_LIB([check], [suite_create],
586 [],
587 [
588 AC_MSG_WARN([library check was not found on the system, unit tests will be disabled])
589 BUILD_TESTS="no"
590 ]
591 )
592 fi
593fi
594
595if test "x$WIN32" = "xyes"; then 563if test "x$WIN32" = "xyes"; then
596 AC_CHECK_LIB(ws2_32, main, 564 AC_CHECK_LIB(ws2_32, main,
597 [ 565 [