summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorirungentoo <irungentoo@gmail.com>2014-07-17 20:44:49 -0400
committerirungentoo <irungentoo@gmail.com>2014-07-17 20:44:49 -0400
commit733c5196011a79ec02851c9d268df4f4181850f3 (patch)
tree8a8e4dd867185ac0633247e5e41b9b43feea2be1 /configure.ac
parentbcfb1261ac4ab5f6470924f473c8c18bc5f98f01 (diff)
Build system now automatically enables epoll support in TCP server
when supported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0dd88da4..174ecbe0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,6 +200,25 @@ AC_ARG_ENABLE([testing],
200 ] 200 ]
201) 201)
202 202
203AC_ARG_ENABLE([[epoll]],
204 [AS_HELP_STRING([[--enable-epoll[=ARG]]], [enable epoll support (yes, no, auto) [auto]])],
205 [enable_epoll=${enableval}],
206 [enable_epoll='auto']
207 )
208
209if test "$enable_epoll" != "no"; then
210 AX_HAVE_EPOLL
211 if test "${ax_cv_have_epoll}" = "yes"; then
212 AC_DEFINE([TCP_SERVER_USE_EPOLL],[1],[define to 1 to enable epoll support])
213 enable_epoll='yes'
214 else
215 if test "$enable_epoll" = "yes"; then
216 AC_MSG_ERROR([[Support for epoll was explicitly requested but cannot be enabled on this platform.]])
217 fi
218 enable_epoll='no'
219 fi
220fi
221
203DEPSEARCH= 222DEPSEARCH=
204LIBSODIUM_SEARCH_HEADERS= 223LIBSODIUM_SEARCH_HEADERS=
205LIBSODIUM_SEARCH_LIBS= 224LIBSODIUM_SEARCH_LIBS=