summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormannol <eniz_vukovic@hotmail.com>2014-07-21 04:10:05 +0200
committermannol <eniz_vukovic@hotmail.com>2014-07-21 04:10:05 +0200
commit79115259a81dc958041f18573f34299c083cebea (patch)
tree594fbf60dc01e2aa78c775c4e2d9977c5b18752f /configure.ac
parent2ca2baf120c5dd4dcdd9c450ef35560b0726136f (diff)
parentb63e4ad88fb93820fb740372f36d74c65b8b7b81 (diff)
Fixed conflicts
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0dd88da4..d1c54c71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,6 +200,25 @@ AC_ARG_ENABLE([testing],
200 ] 200 ]
201) 201)
202 202
203AC_ARG_ENABLE([[epoll]],
204 [AS_HELP_STRING([[--enable-epoll[=ARG]]], [enable epoll support (yes, no, auto) [auto]])],
205 [enable_epoll=${enableval}],
206 [enable_epoll='auto']
207 )
208
209if test "$enable_epoll" != "no"; then
210 AX_HAVE_EPOLL
211 if test "${ax_cv_have_epoll}" = "yes"; then
212 AC_DEFINE([TCP_SERVER_USE_EPOLL],[1],[define to 1 to enable epoll support])
213 enable_epoll='yes'
214 else
215 if test "$enable_epoll" = "yes"; then
216 AC_MSG_ERROR([[Support for epoll was explicitly requested but cannot be enabled on this platform.]])
217 fi
218 enable_epoll='no'
219 fi
220fi
221
203DEPSEARCH= 222DEPSEARCH=
204LIBSODIUM_SEARCH_HEADERS= 223LIBSODIUM_SEARCH_HEADERS=
205LIBSODIUM_SEARCH_LIBS= 224LIBSODIUM_SEARCH_LIBS=
@@ -643,7 +662,7 @@ fi
643if test "x$WIN32" = "xyes"; then 662if test "x$WIN32" = "xyes"; then
644 AC_CHECK_LIB(ws2_32, main, 663 AC_CHECK_LIB(ws2_32, main,
645 [ 664 [
646 WINSOCK2_LIBS="-lws2_32" 665 WINSOCK2_LIBS="-liphlpapi -lws2_32"
647 AC_SUBST(WINSOCK2_LIBS) 666 AC_SUBST(WINSOCK2_LIBS)
648 ], 667 ],
649 [ 668 [