summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBtbN <btbn@btbn.de>2013-10-07 01:58:57 +0200
committerBtbN <btbn@btbn.de>2013-10-07 02:01:16 +0200
commit8d40ddf41727a9022f32531c0a1cc85536db9836 (patch)
treed1c0089e3bbd6d103ca07ece70d9c17cbd7a39dd /configure.ac
parent94691bfe0ed198b282a6cdf49ad8c718fd45afa1 (diff)
Some configuration/build fixes, so building basicaly everything else than the library can be disabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 762736df..81f15eca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,7 @@ fi
28BUILD_DHT_BOOTSTRAP_DAEMON="yes" 28BUILD_DHT_BOOTSTRAP_DAEMON="yes"
29BUILD_NTOX="yes" 29BUILD_NTOX="yes"
30BUILD_TESTS="yes" 30BUILD_TESTS="yes"
31BUILD_TESTING="yes"
31 32
32NCURSES_FOUND="no" 33NCURSES_FOUND="no"
33LIBCONFIG_FOUND="no" 34LIBCONFIG_FOUND="no"
@@ -35,7 +36,7 @@ LIBCHECK_FOUND="no"
35WANT_NACL="no" 36WANT_NACL="no"
36 37
37AC_ARG_ENABLE([nacl], 38AC_ARG_ENABLE([nacl],
38 [AC_HELP_STRING([--enable-tests], [use nacl instead of libsodium (default: disabled)]) ], 39 [AC_HELP_STRING([--enable-nacl], [use nacl instead of libsodium (default: disabled)]) ],
39 [ 40 [
40 if test "x$enableval" = "xno"; then 41 if test "x$enableval" = "xno"; then
41 WANT_NACL="no" 42 WANT_NACL="no"
@@ -78,6 +79,17 @@ AC_ARG_ENABLE([dht-bootstrap-daemon],
78 ] 79 ]
79) 80)
80 81
82AC_ARG_ENABLE([testing],
83 [AC_HELP_STRING([--disable-testing], [build various testing tools (default: auto)]) ],
84 [
85 if test "x$enableval" = "xno"; then
86 BUILD_TESTING="no"
87 elif test "x$enableval" = "xyes"; then
88 BUILD_TESTING="yes"
89 fi
90 ]
91)
92
81DEPSEARCH= 93DEPSEARCH=
82LIBSODIUM_SEARCH_HEADERS= 94LIBSODIUM_SEARCH_HEADERS=
83LIBSODIUM_SEARCH_LIBS= 95LIBSODIUM_SEARCH_LIBS=
@@ -460,9 +472,9 @@ if test "x$WIN32" = "xyes"; then
460fi 472fi
461 473
462AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP_DAEMON, test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes") 474AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP_DAEMON, test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes")
463
464AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes") 475AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes")
465AM_CONDITIONAL(BUILD_NTOX, test "x$BUILD_NTOX" = "xyes") 476AM_CONDITIONAL(BUILD_NTOX, test "x$BUILD_NTOX" = "xyes")
477AM_CONDITIONAL(BUILD_TESTING, test "x$BUILD_TESTING" = "xyes")
466 478
467AC_CONFIG_FILES([Makefile 479AC_CONFIG_FILES([Makefile
468 build/Makefile 480 build/Makefile