summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiadlo <polsha3@gmail.com>2017-11-15 12:48:48 +0300
committerDiadlo <polsha3@gmail.com>2017-11-15 15:22:19 +0300
commitb39cc55d374457f66606096904af9fe7ea6562f6 (patch)
treebdfdbf57bd6b6e757e156b6dad4ab6c6eeb8823d /configure.ac
parentd037f938111c148c6956b58ebfba717e7c7cfb00 (diff)
Add support of IPv6 disabling
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38e3dd82..1ff861cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,6 +193,16 @@ AC_ARG_ENABLE([[epoll]],
193 [enable_epoll='auto'] 193 [enable_epoll='auto']
194 ) 194 )
195 195
196AC_ARG_ENABLE([[ipv6]],
197 [AS_HELP_STRING([[--disable-ipv6[=ARG]]], [use ipv4 in tests (yes, no, auto) [auto]])],
198 [use_ipv6=${enableval}],
199 [use_ipv6='auto']
200 )
201
202if test "$use_ipv6" != "yes"; then
203 AC_DEFINE([USE_IPV6],[0],[define to 0 to force ipv4])
204fi
205
196AX_HAVE_EPOLL 206AX_HAVE_EPOLL
197if test "$enable_epoll" != "no"; then 207if test "$enable_epoll" != "no"; then
198 if test "${ax_cv_have_epoll}" = "yes"; then 208 if test "${ax_cv_have_epoll}" = "yes"; then