summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authoriphydf <iphydf@users.noreply.github.com>2018-01-20 14:22:34 +0000
committeriphydf <iphydf@users.noreply.github.com>2018-01-20 19:05:53 +0000
commitd7583a719a73cf5ec75da7839b2fd2c11d676c45 (patch)
treec7dd6f9ba3e2e937dca98d4c9eb7ae30a0c68eb4 /configure.ac
parentc5976e37eaadf663dc3d0c18376ea023355048f3 (diff)
Remove nTox from the repo.
It's a maintenance burden nobody uses. Let's make toxic the official console client, instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac87
1 files changed, 0 insertions, 87 deletions
diff --git a/configure.ac b/configure.ac
index 22b680a7..18796bdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,6 @@ fi
18 18
19BUILD_DHT_BOOTSTRAP_DAEMON="no" 19BUILD_DHT_BOOTSTRAP_DAEMON="no"
20BUILD_DHT_BOOTSTRAP="no" 20BUILD_DHT_BOOTSTRAP="no"
21BUILD_NTOX="no"
22BUILD_TESTS="yes" 21BUILD_TESTS="yes"
23BUILD_AV="yes" 22BUILD_AV="yes"
24BUILD_TESTING="yes" 23BUILD_TESTING="yes"
@@ -131,17 +130,6 @@ AC_ARG_ENABLE([tests],
131 ] 130 ]
132) 131)
133 132
134AC_ARG_ENABLE([ntox],
135 [AC_HELP_STRING([--enable-ntox], [build nTox client (default: auto)]) ],
136 [
137 if test "x$enableval" = "xno"; then
138 BUILD_NTOX="no"
139 elif test "x$enableval" = "xyes"; then
140 BUILD_NTOX="yes"
141 fi
142 ]
143)
144
145AC_ARG_ENABLE([daemon], 133AC_ARG_ENABLE([daemon],
146 [AC_HELP_STRING([--enable-daemon], [build DHT bootstrap daemon (default: auto)]) ], 134 [AC_HELP_STRING([--enable-daemon], [build DHT bootstrap daemon (default: auto)]) ],
147 [ 135 [
@@ -559,84 +547,10 @@ if test -n "$PKG_CONFIG"; then
559 BUILD_DHT_BOOTSTRAP_DAEMON="no" 547 BUILD_DHT_BOOTSTRAP_DAEMON="no"
560 ]) 548 ])
561 fi 549 fi
562
563 if test "x$BUILD_NTOX" = "xyes"; then
564 PKG_CHECK_MODULES([NCURSES], [ncurses],
565 [
566 NCURSES_FOUND="yes"
567 ],
568 [
569 AC_MSG_WARN([$NCURSES_PKG_ERRORS])
570 ])
571 fi
572else 550else
573 AC_MSG_WARN([pkg-config was not found on your system, will search for libraries manually]) 551 AC_MSG_WARN([pkg-config was not found on your system, will search for libraries manually])
574fi 552fi
575 553
576if (test "x$BUILD_NTOX" = "xyes") && (test "x$NCURSES_FOUND" != "xyes"); then
577 AC_PATH_PROG([CURSES_CONFIG], [ncurses5-config], [no])
578 if test "x$CURSES_CONFIG" != "xno"; then
579 AC_MSG_CHECKING(ncurses cflags)
580 NCURSES_CFLAGS=`${CURSES_CONFIG} --cflags`
581 AC_MSG_RESULT($NCURSES_CFLAGS)
582
583 AC_MSG_CHECKING(ncurses libraries)
584 NCURSES_LIBS=`${CURSES_CONFIG} --libs`
585 AC_MSG_RESULT($NCURSES_LIBS)
586
587 AC_SUBST(NCURSES_CFLAGS)
588 AC_SUBST(NCURSES_LIBS)
589 NCURSES_FOUND="yes"
590 fi
591
592 if test "x$NCURSES_FOUND" != "xyes"; then
593 AC_CHECK_HEADER([curses.h],
594 [],
595 [
596 AC_MSG_WARN([not building nTox client because headers for the curses library were not found on your system])
597 BUILD_NTOX="no"
598 ]
599 )
600 if test "x$BUILD_NTOX" = "xyes"; then
601 if test "x$WIN32" = "xyes"; then
602 AC_CHECK_LIB([pdcurses], [clear],
603 [
604 NCURSES_LIBS="-lpdcurses"
605 AC_SUBST(NCURSES_LIBS)
606 ],
607 [
608 AC_MSG_ERROR([required library pdcurses was not found on your system])
609 BUILD_NTOX="no"
610 ]
611 )
612 else
613 AC_CHECK_LIB([ncurses], [clear],
614 [
615 NCURSES_LIBS="-lncurses"
616 AC_SUBST(NCURSES_LIBS)
617 ],
618 [
619 unset ac_cv_lib_ncurses_clear
620 AC_CHECK_LIB([ncurses], [clear],
621 [
622 NCURSES_LIBS="-lncurses -ltinfo"
623 AC_SUBST(NCURSES_LIBS)
624 ],
625 [
626 AC_MSG_WARN([not building nTox client because required library ncurses was not found on your system])
627 BUILD_NTOX="no"
628 ],
629 [
630 -ltinfo
631 ]
632 )
633 ]
634 )
635 fi
636 fi
637 fi
638fi
639
640if (test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes") && \ 554if (test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes") && \
641 (test "x$LIBCONFIG_FOUND" = "xno"); then 555 (test "x$LIBCONFIG_FOUND" = "xno"); then
642 AC_CHECK_HEADER(libconfig.h, 556 AC_CHECK_HEADER(libconfig.h,
@@ -693,7 +607,6 @@ fi
693AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP_DAEMON, test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes") 607AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP_DAEMON, test "x$BUILD_DHT_BOOTSTRAP_DAEMON" = "xyes")
694AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP, test "x$BUILD_DHT_BOOTSTRAP" = "xyes") 608AM_CONDITIONAL(BUILD_DHT_BOOTSTRAP, test "x$BUILD_DHT_BOOTSTRAP" = "xyes")
695AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes") 609AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes")
696AM_CONDITIONAL(BUILD_NTOX, test "x$BUILD_NTOX" = "xyes")
697AM_CONDITIONAL(BUILD_AV, test "x$BUILD_AV" = "xyes") 610AM_CONDITIONAL(BUILD_AV, test "x$BUILD_AV" = "xyes")
698AM_CONDITIONAL(BUILD_TESTING, test "x$BUILD_TESTING" = "xyes") 611AM_CONDITIONAL(BUILD_TESTING, test "x$BUILD_TESTING" = "xyes")
699AM_CONDITIONAL(WITH_NACL, test "x$WANT_NACL" = "xyes") 612AM_CONDITIONAL(WITH_NACL, test "x$WANT_NACL" = "xyes")