summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Qureshi <sean@tox.im>2014-05-21 17:39:53 -0700
committerSean Qureshi <sean@tox.im>2014-05-21 17:39:53 -0700
commite3a4755b781fe92eb8c6aaadcf7718a4706c6973 (patch)
tree3c8cc0ab98fe466e2decc7ad3fbb36667b4b0c97 /configure.ac
parentbe4559de73c17bcfa396098d6cc48b7a4b1157c6 (diff)
Adds --disable-rt to configure, fixing Android
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cb003036..d42961eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,6 +139,17 @@ AC_ARG_ENABLE([daemon],
139 ] 139 ]
140) 140)
141 141
142AC_ARG_ENABLE([nort],
143 [AC_HELP_STRING([--disable-rt], [Disables the librt check (default: auto)]) ],
144 [
145 if test "x$enableval" = "xno"; then
146 DISABLE_RT="no"
147 elif test "x$enableval" = "xyes"; then
148 DISABLE_RT="yes"
149 fi
150 ]
151)
152
142AC_ARG_ENABLE([testing], 153AC_ARG_ENABLE([testing],
143 [AC_HELP_STRING([--disable-testing], [build various testing tools (default: auto)]) ], 154 [AC_HELP_STRING([--disable-testing], [build various testing tools (default: auto)]) ],
144 [ 155 [
@@ -392,7 +403,7 @@ AC_C_BIGENDIAN
392# Checks for library functions. 403# Checks for library functions.
393AC_FUNC_FORK 404AC_FUNC_FORK
394AC_CHECK_FUNCS([gettimeofday memset socket strchr malloc]) 405AC_CHECK_FUNCS([gettimeofday memset socket strchr malloc])
395if (test "x$WIN32" != "xyes") && (test "x$MACH" != "xyes"); then 406if (test "x$WIN32" != "xyes") && (test "x$MACH" != "xyes") && (test "x$DISABLE_RT" != "xyes"); then
396 AC_CHECK_LIB(rt, clock_gettime, 407 AC_CHECK_LIB(rt, clock_gettime,
397 [ 408 [
398 RT_LIBS="-lrt" 409 RT_LIBS="-lrt"