summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjin-eld <jin at mediatomb dot cc>2013-08-26 22:08:43 +0300
committerjin-eld <jin at mediatomb dot cc>2013-08-26 22:08:43 +0300
commited1c130ebced51e48b2a8c600e5f7e68fc54dd85 (patch)
tree4f0267dba2d4c6fb7d7694dccd93085b1c3e22b7 /configure.ac
parent7ce599d1807d0d8e2e86f9691f52a59b48f2c9e6 (diff)
Move extra libtool options into configure
This should allow to keep the libtool options all in one place and at the same time define different options depending on the host. Made sure that -no-undefined is set only on Win32. Although no side effects on Linux and OSX have been observed so far, it's probably better to play it safe; it does not seem to be needed/does not seem to matter on *nix, only required for Win32.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 285c3ac5..64d53dec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,17 @@ AM_INIT_AUTOMAKE([1.10 -Wall])
10m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])]) 10m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
11AC_CONFIG_MACRO_DIR([m4]) 11AC_CONFIG_MACRO_DIR([m4])
12 12
13LIBTOXCORE_LT_VERSION=0:0:0
14dnl
15dnl current:revision:age
16dnl
17dnl current: increment if interfaces have been added, removed or changed
18dnl revision: increment if source code has changed, set to zero if current is
19dnl incremented
20dnl age: increment if interfaces have been added, set to zero if
21dnl interfaces have been removed or changed
22EXTRA_LT_LDFLAGS="-version-info $LIBTOXCORE_LT_VERSION"
23
13if test "x${prefix}" = "xNONE"; then 24if test "x${prefix}" = "xNONE"; then
14 prefix="${ac_default_prefix}" 25 prefix="${ac_default_prefix}"
15fi 26fi
@@ -106,6 +117,7 @@ case $host_os in
106 WIN32="yes" 117 WIN32="yes"
107 AC_MSG_WARN([nTox is not supported on $host_os yet, disabling]) 118 AC_MSG_WARN([nTox is not supported on $host_os yet, disabling])
108 BUILD_NTOX="no" 119 BUILD_NTOX="no"
120 EXTRA_LT_LDFLAGS="$EXTRA_LT_LDFLAGS -no-undefined"
109 ;; 121 ;;
110 *solaris*) 122 *solaris*)
111 LIBS="$LIBS -lssp -lsocket -lnsl" 123 LIBS="$LIBS -lssp -lsocket -lnsl"
@@ -118,6 +130,8 @@ case $host_os in
118esac 130esac
119AM_CONDITIONAL(WIN32, test "x$WIN32" = "xyes") 131AM_CONDITIONAL(WIN32, test "x$WIN32" = "xyes")
120 132
133AC_SUBST(EXTRA_LT_LDFLAGS)
134
121# Checks for libraries. 135# Checks for libraries.
122LIBSODIUM_LIBS= 136LIBSODIUM_LIBS=
123LIBSODIUM_LDFLAGS= 137LIBSODIUM_LDFLAGS=