summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorirungentoo <irungentoo@gmail.com>2014-05-10 16:09:44 -0400
committerirungentoo <irungentoo@gmail.com>2014-05-10 16:09:44 -0400
commitff4368add70d4e36dd553fdc32efe38bdef677b9 (patch)
tree317872cf8a3084e344a70c6724d5d0443780be60 /configure.ac
parent1e485b2c2f210f173dbae0a480e43daadd32a71a (diff)
Fixed build by adding librt to build system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 34038517..7756e6b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,6 +388,17 @@ AC_C_BIGENDIAN
388# Checks for library functions. 388# Checks for library functions.
389AC_FUNC_FORK 389AC_FUNC_FORK
390AC_CHECK_FUNCS([gettimeofday memset socket strchr malloc]) 390AC_CHECK_FUNCS([gettimeofday memset socket strchr malloc])
391if test "x$WIN32" != "xyes"; then
392 AC_CHECK_LIB(rt, clock_gettime,
393 [
394 RT_LIBS="-lrt"
395 AC_SUBST(RT_LIBS)
396 ],
397 [
398 AC_MSG_ERROR([required library rt was not found on your system])
399 ]
400 )
401fi
391 402
392if test "x$BUILD_AV" = "xyes"; then 403if test "x$BUILD_AV" = "xyes"; then
393 AX_PTHREAD( 404 AX_PTHREAD(