summaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorChloride Cull <steamruler@gmail.com>2013-08-03 18:25:12 +0200
committerChloride Cull <steamruler@gmail.com>2013-08-03 18:25:12 +0200
commitadd9c0b6dc8b2aeaffdf69aaee837037ef9b81bc (patch)
tree7e3eccb7e22d5db72847b9f0edd45f2adddff351 /core/CMakeLists.txt
parent08fbaf0c53556da5d57eeec60a14a0baf65e8aa9 (diff)
Changed CMake options to compile the core shared
It is now compiled under 'toxcore' instead of just 'core' to be able to be installed without conflicts.
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 44ae980c..36acb6cf 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -1,5 +1,5 @@
1cmake_minimum_required(VERSION 2.6.0) 1cmake_minimum_required(VERSION 2.6.0)
2project(core C) 2project(toxcore C)
3 3
4if(WIN32) 4if(WIN32)
5 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/) 5 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/)
@@ -16,4 +16,4 @@ set(core_sources
16 LAN_discovery.c 16 LAN_discovery.c
17 Messenger.c) 17 Messenger.c)
18 18
19add_library(core ${core_sources}) 19add_library(toxcore SHARED ${core_sources})