summaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorirungentoo <irungentoo@gmail.com>2013-08-23 14:28:40 -0700
committerirungentoo <irungentoo@gmail.com>2013-08-23 14:28:40 -0700
commite2aa8161adc85795fe4d63d4642f47e90937ddc2 (patch)
tree72543192dae738140bafcf074fcf8326528fa523 /core/CMakeLists.txt
parentf8f550e2f0604fd4491c9ff01f9843573a5a9b43 (diff)
parent33ee73fffaf0fb44d280b8bae16ec9dae15956d7 (diff)
Merge pull request #519 from manuel-arguelles/pcfile
Add pkg-config file
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 49ca7c83..ecbb65c2 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -37,3 +37,9 @@ if(WIN32)
37 target_link_libraries(toxcore ws2_32) 37 target_link_libraries(toxcore ws2_32)
38endif() 38endif()
39 39
40execute_process(COMMAND git rev-list HEAD --count OUTPUT_VARIABLE COMMIT)
41
42# Write pkgconfig-file:
43include(InstallPkgConfigFile)
44install_pkg_config_file(toxcore CFLAGS LIBS -ltoxcore REQUIRES VERSION 0.1.1_r${COMMIT})
45