summaryrefslogtreecommitdiff
path: root/other/CMakeLists.txt
diff options
context:
space:
mode:
authorMaxim Biro <nurupo.contributions@gmail.com>2013-08-20 22:39:31 -0400
committerMaxim Biro <nurupo.contributions@gmail.com>2013-08-20 22:54:14 -0400
commit6a2569c43204fc74546d52cfef20ce6e36bfb22c (patch)
treefd7df2e2bf2b2bf2221c9cdd203b797ee58d84fa /other/CMakeLists.txt
parentc12853275c03ca6153c9424f29220bc5b8903875 (diff)
Fixed DHTservers' path for Windows
Diffstat (limited to 'other/CMakeLists.txt')
-rw-r--r--other/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/other/CMakeLists.txt b/other/CMakeLists.txt
index 871a9e92..7e6c9eb9 100644
--- a/other/CMakeLists.txt
+++ b/other/CMakeLists.txt
@@ -1,13 +1,10 @@
1cmake_minimum_required(VERSION 2.6.0) 1cmake_minimum_required(VERSION 2.6.0)
2 2
3cmake_policy(SET CMP0011 NEW) 3cmake_policy(SET CMP0011 NEW)
4SET(USER_NAME $ENV{USERNAME} CACHE STRING UserName)
5
6include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/DHT_bootstrap.cmake)
7 4
8if(WIN32) 5if(WIN32)
9 file(MAKE_DIRECTORY "C:/Users/${USER_NAME}/AppData/Roaming/.config/tox") 6 file(MAKE_DIRECTORY "$ENV{APPDATA}/.config/tox")
10 file(INSTALL DHTservers DESTINATION "C:/Users/${USER_NAME}/AppData/Roaming/.config/tox") 7 file(INSTALL DHTservers DESTINATION "$ENV{APPDATA}/.config/tox")
11else() 8else()
12 set(HOME "$ENV{HOME}") 9 set(HOME "$ENV{HOME}")
13 if(APPLE) 10 if(APPLE)
@@ -19,6 +16,8 @@ else()
19 endif() 16 endif()
20endif() 17endif()
21 18
19include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/DHT_bootstrap.cmake)
20
22if(LINUX) 21if(LINUX)
23 add_subdirectory(bootstrap_serverdaemon) 22 add_subdirectory(bootstrap_serverdaemon)
24endif() 23endif()