summaryrefslogtreecommitdiff
path: root/testing/toxic/CMakeLists.txt
diff options
context:
space:
mode:
authorSean Qureshi <stqism@risingstormgames.com>2013-08-07 18:52:11 -0700
committerSean Qureshi <stqism@risingstormgames.com>2013-08-07 18:52:11 -0700
commitb3e02d9c9da0a508e52e60037f0f65ccf042f95d (patch)
tree1ee45f2263f862cb84419bc91d585efe1f691483 /testing/toxic/CMakeLists.txt
parent6a84fd6f0b33d1c07125d43e80a19d2086682d95 (diff)
Adds full -D support to toxics versioning, includes the commit number
Diffstat (limited to 'testing/toxic/CMakeLists.txt')
-rw-r--r--testing/toxic/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/testing/toxic/CMakeLists.txt b/testing/toxic/CMakeLists.txt
index f30d8e9e..38f02dc6 100644
--- a/testing/toxic/CMakeLists.txt
+++ b/testing/toxic/CMakeLists.txt
@@ -1,6 +1,9 @@
1cmake_minimum_required(VERSION 2.6.0) 1cmake_minimum_required(VERSION 2.6.0)
2project(toxic C) 2project(toxic C)
3 3
4execute_process(COMMAND git rev-list HEAD --count OUTPUT_VARIABLE COMMIT)
5SET(GCC_COVERAGE_COMPILE_FLAGS '-DTOXICVER="0.1.1_r${COMMIT}"')
6add_definitions(${GCC_COVERAGE_COMPILE_FLAGS})
4set(exe_name toxic) 7set(exe_name toxic)
5 8
6add_executable(${exe_name} 9add_executable(${exe_name}